Bug 230181 - anaconda identifies multiple drives as a multipath
anaconda identifies multiple drives as a multipath
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-27 00:41 EST by Jack Neely
Modified: 2009-02-10 21:15 EST (History)
4 users (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 15:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (13.08 KB, text/plain)
2007-02-27 00:41 EST, Jack Neely
no flags Details
dmesg (16.00 KB, text/plain)
2007-02-27 00:42 EST, Jack Neely
no flags Details
hdparm -I /dev/sda (1.88 KB, text/plain)
2007-02-28 13:46 EST, Jack Neely
no flags Details
hdparm -I /dev/sdb (1.88 KB, text/plain)
2007-02-28 13:47 EST, Jack Neely
no flags Details

  None (edit)
Description Jack Neely 2007-02-27 00:41:00 EST
Description of problem:
I have installed a Promise SATA controller and 2 identical Seagate HDs in a Dell
4550.

  02:01.0 Mass storage controller: Promise Technology, Inc. PDC40718 (SATA 300
TX4) (rev 02)

The kernel correctly sees /dev/sda and /dev/sdb and I have done some tests to
partition and check for DOA HDs.  (Bad blocks test, etc.)

Anaconda from the FC6 CDs takes me to the partition configuration screens and
presents me with /dev/mapper/mpathp0 and /dev/mapper/mpath1.  This isn't right.

Version-Release number of selected component (if applicable):
anaconda 11.1.1.3 (FC6 gold ISOs)

How reproducible:
I pulled up this: http://www.fedoraforum.org/forum/archive/index.php/t-143840.html
Comment 1 Jack Neely 2007-02-27 00:41:00 EST
Created attachment 148846 [details]
Anaconda log
Comment 2 Jack Neely 2007-02-27 00:42:26 EST
Created attachment 148847 [details]
dmesg
Comment 3 Jack Neely 2007-02-28 13:46:05 EST
Talked with pjones on irc a bit.  He suggested I try installing with the
"nompath" option to the boot kernel which did work.  I was able to install normally.

He also suggested that the serial numbers of my new hard drives were probably
the same, however they are indeed different.  I'm attaching the hdparm -I output
from both HDs.
Comment 4 Jack Neely 2007-02-28 13:46:43 EST
Created attachment 148948 [details]
hdparm -I /dev/sda
Comment 5 Jack Neely 2007-02-28 13:47:18 EST
Created attachment 148949 [details]
hdparm -I /dev/sdb
Comment 6 Greg Diebel 2007-06-12 16:42:55 EDT
This happens for me on F7, using 2 identical Maxtor STM3160812AS 160GB SATA
drives. The board is Intel D945GCCR (no onboard RAID) As per #3, the drives do
not have identical serial numbers

Using nompath resolves the issue. If this situation occurs frequently with
multipath why is it the default?
Comment 7 Jack Neely 2007-06-12 16:48:30 EDT
I can confirm that my machine has the same bug in F7 as well.
Comment 8 Harold Pritchett 2007-06-12 19:34:13 EDT
I also have the same problem with F7.  Two Maxtor 500Gb drives to be formatted
as raid1 and LVM.  O/S to be installed on a third drive (80Gb WDC)

Drives:
/dev/sda WDC WD800BB-32FRA0
/dev/sdb MAXTOR STM350063A
/dev/sdc MAXTOR STM350063A

Machine is a 5 year old P4 (TYAN S2090 Trinity i845 MotherBoard), 1.6 GHz P4
processor 1GB ram.
Comment 9 Bug Zapper 2008-04-04 02:23:23 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 10 Jack Neely 2008-04-04 15:31:19 EDT
This bug is no longer reproducible in newer versions of Fedora.
Comment 11 randygalbraith 2009-02-10 21:15:53 EST
FWIW: The comments in this bug regarding the "nompath" option (thank you!) helped me work around this very issue with my Fedora 10 install yesterday (February 9, 2009).  Until I ran the install with the nompath option I could not get Fedora to see my two 320gb SATA Maxstor drives.  I tried various BIOS settings and the nodmraid option which did not work.  I even dd if=/dev/zero of=/dev/sd[ab] when someone suggested "meta data" on the drives may be leading Fedora install program to only suggest /dev/mapper option.
  -Randy Galbraith

Note You need to log in before you can comment on or make changes to this bug.