Bug 23021 - chkconfig values change request (S90 -> S78)
Summary: chkconfig values change request (S90 -> S78)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-30 07:44 UTC by jve
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-30 07:44:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jve 2000-12-30 07:44:46 UTC
The chkconfig line in the init.d script for mysql uses 90 for both the S 
and K sequence numbers.

The K number should be 10, but that's not the problem...

The problem is that the Apache httpd S number is 85, which means that 
Apache starts up before the internal database server (mysql), and for a few 
seconds (or however long it takes to get through any startup scripts from 
85 to 90), the apache CGI connections to Mysql fail because mysqld isn't 
running.

Can you please change the chkconfig S and K numbers in the Mysql init.d 
script to somewhere around 78 and 22?  That puts it before the externally 
accessible servers that start up in the 80's.

Thanks.

Comment 1 Trond Eivind Glomsrxd 2000-12-30 13:08:15 UTC
We didn't ship mysql in Red Hat Linux 6.2 - where did you get it?
Anyway, for the version currently shipping in 7, the values are 85 (start) 15 (stop)


Note You need to log in before you can comment on or make changes to this bug.