Bug 230213 - Internal Server Error when trying to subscribe system to child channels
Internal Server Error when trying to subscribe system to child channels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Brandon Perkins
: Reopened
Depends On:
Blocks: 166615
  Show dependency treegraph
 
Reported: 2007-02-27 09:56 EST by Jeff Needle
Modified: 2007-04-18 14:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 09:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
webqa traceback (11.48 KB, text/plain)
2007-02-27 10:00 EST, Beth Nackashi
no flags Details

  None (edit)
Description Jeff Needle 2007-02-27 09:56:33 EST
Description of problem:
Tried to add system milkbones.boston.devel.redhat.com (system_id: 1007272204) to
child channels and got "Internal Server Error".  Happens 100% of the time for
that system.  If relevant, milkbones is a xen install.

Version-Release number of selected component (if applicable):
rhn500

How reproducible:
100% on this one zen instance - haven't tried others because they all became
unregistered somehow.

Beth to attach traceback.
Comment 1 Beth Nackashi 2007-02-27 10:00:21 EST
Created attachment 148865 [details]
webqa traceback
Comment 2 Jeff Needle 2007-02-27 10:06:08 EST
Could be a duplicate of 230084.
Comment 3 Mike McCune 2007-02-27 16:56:49 EST
I couldn't find a specific BZ in 500 Hosted that addresses this, but I
definitely fixed it as part of:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229909
Comment 4 Brandon Perkins 2007-02-27 23:02:50 EST
Need Info.  Three pieces of information:

1) What is the specific Base Software Channel for this system (for example: Red
Hat Enterprise Linux (v. 5 for 64-bit x86_64))?

2) Which specific Software Channel were you trying to subsribe to (for example:
RHEL Supplementary (v. 5 for 64-bit x86_64))?

3) Do you have free software channel entitlements available to do this?

If you answered yes to three...this is a new bug...and we'll really need the
first two pieces of information.  If you answered no to three, then its
definitely a duplicate of Bugzilla Bug 229909: Attempting to add channel
subscription to a system that org has entitlement to, but is out of entitlements
causes ISE.  I don't want to close this until I'm sure.

Please try it again now, as we've done QA Push 10 and Bug 229909 was fixed in
this push.
Comment 5 Mike McCune 2007-02-28 02:32:22 EST
no harm in a little bit of extra testing :-)

Jeff feel free to ping me on #rhn if you have questions.
Comment 7 Jeff Needle 2007-02-28 09:27:19 EST
Totally unable to reprouce this against the push 10 code, so
closing->currentrelease.
Comment 8 Beth Nackashi 2007-02-28 09:30:58 EST
Moving to verified.
Comment 9 Miroslav Suchý 2007-03-09 08:39:21 EST
*** Bug 231596 has been marked as a duplicate of this bug. ***
Comment 10 David Kovalsky 2007-03-09 08:49:48 EST
I've also experienced this issue a few minutes ago on
sputnik-webqa.brq.redhat.com. 3 RHEL5 machines registered, they all share the
same problem. Yum works fine. But when trying to alter channels (unsubscribe) I
get '500 ISE'. 

2 machines RHEL5 Server with all sub channels selected, one machine RHEL5 Client
with all sub channels selected.

Comment 11 Brandon Perkins 2007-03-09 17:46:08 EST
I don't see this in stage, so I'm moving to release_pending.
Comment 12 Brandon Perkins 2007-03-13 09:54:34 EDT
Closed in rhn500h Release.

Note You need to log in before you can comment on or make changes to this bug.