Bug 230213 - Internal Server Error when trying to subscribe system to child channels
Summary: Internal Server Error when trying to subscribe system to child channels
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn500
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike McCune
QA Contact: Brandon Perkins
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 166615
TreeView+ depends on / blocked
 
Reported: 2007-02-27 14:56 UTC by Jeff Needle
Modified: 2007-04-18 18:00 UTC (History)
3 users (show)

Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 13:54:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
webqa traceback (11.48 KB, text/plain)
2007-02-27 15:00 UTC, Beth Nackashi
no flags Details

Description Jeff Needle 2007-02-27 14:56:33 UTC
Description of problem:
Tried to add system milkbones.boston.devel.redhat.com (system_id: 1007272204) to
child channels and got "Internal Server Error".  Happens 100% of the time for
that system.  If relevant, milkbones is a xen install.

Version-Release number of selected component (if applicable):
rhn500

How reproducible:
100% on this one zen instance - haven't tried others because they all became
unregistered somehow.

Beth to attach traceback.

Comment 1 Beth Nackashi 2007-02-27 15:00:21 UTC
Created attachment 148865 [details]
webqa traceback

Comment 2 Jeff Needle 2007-02-27 15:06:08 UTC
Could be a duplicate of 230084.

Comment 3 Mike McCune 2007-02-27 21:56:49 UTC
I couldn't find a specific BZ in 500 Hosted that addresses this, but I
definitely fixed it as part of:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229909

Comment 4 Brandon Perkins 2007-02-28 04:02:50 UTC
Need Info.  Three pieces of information:

1) What is the specific Base Software Channel for this system (for example: Red
Hat Enterprise Linux (v. 5 for 64-bit x86_64))?

2) Which specific Software Channel were you trying to subsribe to (for example:
RHEL Supplementary (v. 5 for 64-bit x86_64))?

3) Do you have free software channel entitlements available to do this?

If you answered yes to three...this is a new bug...and we'll really need the
first two pieces of information.  If you answered no to three, then its
definitely a duplicate of Bugzilla Bug 229909: Attempting to add channel
subscription to a system that org has entitlement to, but is out of entitlements
causes ISE.  I don't want to close this until I'm sure.

Please try it again now, as we've done QA Push 10 and Bug 229909 was fixed in
this push.

Comment 5 Mike McCune 2007-02-28 07:32:22 UTC
no harm in a little bit of extra testing :-)

Jeff feel free to ping me on #rhn if you have questions.

Comment 7 Jeff Needle 2007-02-28 14:27:19 UTC
Totally unable to reprouce this against the push 10 code, so
closing->currentrelease.

Comment 8 Beth Nackashi 2007-02-28 14:30:58 UTC
Moving to verified.

Comment 9 Miroslav Suchý 2007-03-09 13:39:21 UTC
*** Bug 231596 has been marked as a duplicate of this bug. ***

Comment 10 David Kovalsky 2007-03-09 13:49:48 UTC
I've also experienced this issue a few minutes ago on
sputnik-webqa.brq.redhat.com. 3 RHEL5 machines registered, they all share the
same problem. Yum works fine. But when trying to alter channels (unsubscribe) I
get '500 ISE'. 

2 machines RHEL5 Server with all sub channels selected, one machine RHEL5 Client
with all sub channels selected.



Comment 11 Brandon Perkins 2007-03-09 22:46:08 UTC
I don't see this in stage, so I'm moving to release_pending.

Comment 12 Brandon Perkins 2007-03-13 13:54:34 UTC
Closed in rhn500h Release.


Note You need to log in before you can comment on or make changes to this bug.