Bug 230214 - [RHEL4.5 Beta] Installer cannot detect disks on Promise stex adapter
Summary: [RHEL4.5 Beta] Installer cannot detect disks on Promise stex adapter
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.5
Hardware: All Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: David Lehman
QA Contact:
URL:
Whiteboard:
Keywords:
: 234229 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 15:07 UTC by Jun'ichi NOMURA
Modified: 2009-06-19 15:26 UTC (History)
6 users (show)

Fixed In Version: RHBA-2007-0215
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:30:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0215 normal SHIPPED_LIVE anaconda, and rhpl bug fix update 2007-05-01 17:16:50 UTC

Description Jun'ichi NOMURA 2007-02-27 15:07:32 UTC
Description of problem:
Installer cannot detect disks connected to Promise SuperTrak EX
series adapter (EX4350, EX8350, etc.) driven by stex.ko.
  - modules.cgz and pci.ids in initrd.img of the installer don't contain
    stex.ko and entries for the stex adapters, respectively.
    On the other hand, kernel package contains the driver and
    hwdata package contains proper pci.ids file.
  - anaconda/loader2/module-info doesn't have an entry for "stex".
So it looks this is a problem of anaconda or installer image.

Version-Release number of selected component (if applicable):
kernel-2.6.9-48.EL
anaconda-10.1.1.62-1
hwdata-0.146.24.EL-3

How reproducible:
Always

Steps to Reproduce:
1. Try to install to the disks connected to Promise EX4350 or EX8350
2.
3.
  
Actual results:
Installation fails due to the absense of installable disk drive

Expected results:
Disks should be detected

Additional info:

# grep 8350 /usr/share/hwdata/pci.ids 
        8350  80333 [SuperTrak EX8350/EX16350], 80331 [SuperTrak EX8300/EX16300]
# grep 8350 /lib/modules/2.6.9-48.EL/modules.pcimap 
stex                 0x0000105a 0x00008350 0xffffffff 0xffffffff 0x00000000
0x00000000 0x0
# ls -l /lib/modules/2.6.9-48.EL/kernel/drivers/scsi/stex.ko 
-rwxr--r--  1 root root 28072 Feb 13 12:39
/lib/modules/2.6.9-48.EL/kernel/drivers/scsi/stex.ko
# modinfo /lib/modules/2.6.9-48.EL/kernel/drivers/scsi/stex.ko 
filename:       /lib/modules/2.6.9-48.EL/kernel/drivers/scsi/stex.ko
version:        3.0.0.1 338F79082A7D490A2B57033
license:        GPL
description:    Promise Technology SuperTrak EX Controllers
author:         Ed Lin
alias:          pci:v0000105Ad00008650sv*sd*bc*sc*i*
alias:          pci:v0000105Ad00008302sv*sd*bc*sc*i*
alias:          pci:v0000105Ad00008301sv*sd*bc*sc*i*
alias:          pci:v0000105Ad00004302sv*sd*bc*sc*i*
alias:          pci:v0000105Ad00004301sv*sd*bc*sc*i*
alias:          pci:v0000105Ad0000F350sv*sd*bc*sc*i*
alias:          pci:v0000105Ad0000C350sv*sd*bc*sc*i*
alias:          pci:v0000105Ad00008350sv*sd*bc*sc*i*
depends:        scsi_mod
vermagic:       2.6.9-48.EL gcc-3.4

# zcat isolinux/initrd.img > initrd
# mount initrd /mnt/0
# zcat /mnt/0/modules/modules.cgz |cpio -t|grep stex
15475 blocks
# grep 8350 /mnt/0/modules/pci.ids
#

RHEL5 anaconda contains the following entry in module-info:
  stex
        scsi_hostadapter
        "Promise SuperTrak EX"
and the installer can detect the device.

Comment 5 Mike Gahagan 2007-03-27 20:45:27 UTC
*** Bug 234229 has been marked as a duplicate of this bug. ***

Comment 6 Pete Graner 2007-03-30 15:31:00 UTC
The decision in the RHEL meeting was to commit the patch to CVS and include it
in 4.5 *ONLY* if we have to respin anaconda prior to 4.5 GA. Using driver disks
would be the workaround until it would come out in 4.6

Comment 7 Kevin Krafthefer 2007-04-04 19:25:24 UTC
anaconda has not been respun. moving to 4.6 so this is not closed.

Comment 8 Larry Troan 2007-04-05 23:59:33 UTC
Requesting SEG to create driver disk based off 5.1 kernel and for Engineering to
commit to including anaconda support in 4.6.

Comment 19 Red Hat Bugzilla 2007-05-01 17:30:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0215.html



Note You need to log in before you can comment on or make changes to this bug.