Bug 230223 - glXGetCurrentContext symbol missing in -devel
Summary: glXGetCurrentContext symbol missing in -devel
Status: CLOSED DUPLICATE of bug 229808
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa   
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 16:16 UTC by Balint Cristian
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 16:39:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Balint Cristian 2007-02-27 16:16:59 UTC
Description of problem:
glXGetCurrentContext missing in -devel

Version-Release number of selected component (if applicable):
mesa-libGL-devel-6.5.2-5.fc7

How reproducible:
nm -D /usr/lib/libGL.so | grep glXGetCurrentContext

Steps to Reproduce:
1. nm -D /usr/lib/libGL.so | grep glXGetCurrentContext

  
Actual results:
nm -D /usr/lib/libGL.so | grep glXGetCurrentContext
shows nothing.

Expected results:
on my rhel5-beta e.g:
nm -D /usr/lib64/libGL.so | grep glXGetCurrentContext
00000037728231c0 T __glXGetCurrentContext
0000003772823220 T glXGetCurrentContext


Additional info:
Unable to compile bz#227646 on fc-devel, i get:

..... -lGL -lGLU -L/usr/lib/
do_zoom.c:264: undefined reference to `glXGetCurrentContext'

On rhel5-beta e.g works fine.

Comment 1 Adam Jackson 2007-02-27 16:39:45 UTC
Already fixed in 6.5.2-6

*** This bug has been marked as a duplicate of 229808 ***


Note You need to log in before you can comment on or make changes to this bug.