This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 230240 - cannot read Flash card
cannot read Flash card
Status: CLOSED DUPLICATE of bug 230155
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-27 12:58 EST by Florin Andrei
Modified: 2013-03-05 22:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 13:23:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (153.06 KB, image/png)
2007-02-27 12:58 EST, Florin Andrei
no flags Details

  None (edit)
Description Florin Andrei 2007-02-27 12:58:55 EST
Description of problem:
While being logged in to my Gnome desktop:
I plugged in the USB port a 4-port Flash card reader. It showed up in the
Computer window as 4 new drive icons (see attached screenshot).
Then I plugged into the reader an SD card. An error showed up, saying:

Cannot mount volume.
Error org.freedesktop.Hal.PermissionDenied.
Permission denied: Not in active session

Version-Release number of selected component (if applicable):
hal-0.5.9-0.git20070218.fc7

How reproducible:
only tried once, I'm in a hurry

Steps to Reproduce:
1. see above
2. 
3.
  
Actual results:
can't read card

Expected results:
duh

Additional info:
Comment 1 Florin Andrei 2007-02-27 12:58:56 EST
Created attachment 148879 [details]
screenshot
Comment 2 Florin Andrei 2007-02-27 13:02:39 EST
I unplugged the card, unplugged the reader, then logged out.
Plugged back the reader, logged in (so I'm logged in after the reader was
connected).
Plugged the card back in.

Same error.
Comment 3 David Zeuthen 2007-02-27 13:06:17 EST
If you're running SELinux in enforcing mode, please close as dupe of bug 230155

If you're not logging in via gdm, please close as dupe of bug 228110

Thanks.
Comment 4 Florin Andrei 2007-02-27 13:14:12 EST
SELinux is enforcing and I'm using gdm.
But I'm doing "tail -f /var/log/audit/audit.log" and there are no messages when
the error occurs. Is it still a SELinux problem?
If it is, what can I do to enable this functionality (other than switching from
enforcing mode which I do not want to do)?
Comment 5 David Zeuthen 2007-02-27 13:23:54 EST

*** This bug has been marked as a duplicate of 230155 ***
Comment 6 David Zeuthen 2007-02-27 13:26:25 EST
I'm not sure why SELinux is logging errors - that's also a problem in 230155...
Comment 7 Florin Andrei 2007-02-27 13:28:29 EST
Thanks, I'll watch the other bug then.
Comment 8 Bill Nottingham 2007-03-02 12:28:43 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Note You need to log in before you can comment on or make changes to this bug.