Bug 230329 - Gnucash fails to start (wrong scheme modules paths + names).
Gnucash fails to start (wrong scheme modules paths + names).
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 07:40 EST by Oron Peled
Modified: 2014-03-16 23:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 09:12:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oron Peled 2007-02-28 07:40:36 EST
Description of problem:

Trying to run the latest gnucash aborts with an error message.

Version-Release number of selected component (if applicable):
gnucash-2.0.5-1.fc6

How reproducible:
Simply run this gnucash version.

Actual results:
Gnucash aborts with the following error message:
ERROR: Could not find slib/require.scm in  ("/usr/share/guile/site"
"/usr/share/gnucash/guile-modules" "/usr/share/gnucash/scm" ""
"/usr/share/guile/site" "/usr/share/guile/1.8" "/usr/share/guile")

I located the missing file in /usr/share/slib which is part
of the installed package: slib-3a3-2

After looking in the /usr/bin/gnucash startup script I tried
the following workaround:
  env GUILE_LOAD_PATH=/usr/share gnucash

And gnucash aborted again with the following error message:
ERROR: In procedure open-file:
ERROR: No such file or directory: "/usr/share/slib/mklibcat"



Expected results:


Additional info:
Comment 1 Oron Peled 2007-02-28 09:12:37 EST
Found the culprit and fixed it:
 - Had another host with a working gnucash.
 - strace -fe open -o out.txt /usr/bin/gnucash
 - Found /usr/share/guile/site/slib/require.scm
 - /usr/share/guile/site/slib is a symlink to /usr/share/slib
 - The link was missing on the faulty host
 - rpmverify gnucash guile slib got clean on both hosts.
 - rpmquery -f /usr/share/guile/site/* on the good
   host shows no package owns it.
 - rpmquery --scripts on the suspected packages shows nothing relevant.
 - Hmmm..... maybe another package is involved? which?
 - Arrrggg... those triggers.
 - rpmquery --triggers guile
 - Manually run these commands on the faulty host.
 - All is in order.

Note You need to log in before you can comment on or make changes to this bug.