Bug 23048 - memory leak
memory leak
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-30 21:38 EST by Need Real Name
Modified: 2007-03-26 23:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-30 21:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-30 21:38:56 EST
whenever i boot red hat linux 7, it start off with 76000 KB of free 
physical memory.  i have a total of 128 MB of memory.  then i start an 
application like staroffice or realplayer or emacs or a game.  i know that 
when you start an application, that the operating system has to allocate 
memory for the program to be run.  my problem is this:  when i close the 
application, i type free, and it looks like linux has not deallocated the 
memory it used.  when i really loaded it, and then killed those apps, it 
said that i only had about 3000 KB of physical memory remaining while my 
swap file was hardly being used.  is there some kind of memory leak going 
on, is this the way linux works, or this is nothing to worry about?
Comment 1 Bill Nottingham 2001-01-02 01:17:16 EST
It's caching files in memory - look at
the +/- buffers/cache line.

Note You need to log in before you can comment on or make changes to this bug.