Bug 230539 - PC does not play sound and no PCM device displayed
PC does not play sound and no PCM device displayed
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-01 07:07 EST by Craig Lister
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 05:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Generated from Audio config system tab (54.36 KB, text/plain)
2007-03-01 07:07 EST, Craig Lister
no flags Details

  None (edit)
Description Craig Lister 2007-03-01 07:07:16 EST
Description of problem:
Cannot play sound. No PCM device displayed in audio config screen for selected card.

Version-Release number of selected component (if applicable):
Advanced Linux Sound Architecture Driver Version 1.0.13

How reproducible:
On my machine, every time

Steps to Reproduce:
1. Run /usr/bin/system-config-soundcard
2.
3.
  
Actual results:
No sound and no PCM device displayed

Expected results:
PCM device displayed.

Additional info:
Note: If this system is booted under XP the sound workd perfectly. The sound
also worked perfectly under FC5 x86_64.
Comment 1 Craig Lister 2007-03-01 07:07:16 EST
Created attachment 149011 [details]
Generated from Audio config system tab
Comment 2 Craig Lister 2007-03-02 02:14:52 EST
I have checked here :-

http://people.redhat.com/stransky/alsa/

but that didn't shed any light. I also believe that I am running off the latest
alsa drivers ie Advanced Linux Sound Architecture Driver Version 1.0.13. Is that
correct?
Comment 3 Martin Stransky 2007-03-06 12:35:47 EST
hm, it looks like a problem in drivers:

Intel ICH: probe of 0000:00:04.0 failed with error -12

The latest drivers are 1.0.14rc3, on my page are 1.0.14rc2.
Comment 4 Craig Lister 2007-03-06 16:44:11 EST
I am up to date from the Fedora site?? How come I need to load extra drivers??
Where do I get them from if not from the Fedora updates??
Comment 5 Martin Stransky 2007-03-07 05:41:32 EST
They are not in fedora updates.
Comment 6 Richard Steck 2007-03-07 16:51:51 EST
Identical problem started here today after updating from FC5 to FC6.  Have 
sound with WinXP.

Problem also started on an FC6 system which went through normal updates today. 
Something killed all sound.  My Default PCM device,  STAC92xx Analog 
disappeared.


Comment 7 Craig Lister 2007-03-07 18:49:49 EST
Do you have a link where I may get the latest drivers?
Comment 9 Richard Steck 2007-03-08 11:07:03 EST
When I try to install  alsa-driver-1.0.14-58_rc3.fc6.at.i386.rpm , I am told
there is a missing dependency for  kmdl-1.0.14-58_rc3.fc6.at

Please tell me where to get the latter.

Comment 10 Craig Lister 2007-03-08 20:33:08 EST
I have the same problem :-

[root@cjlhpc Desktop]# rpm -Uhv alsa-driver-1.0.14-57_rc2.fc6.at.i386.rpm
warning: alsa-driver-1.0.14-57_rc2.fc6.at.i386.rpm: Header V3 DSA signature:
NOKEY, key ID 66534c2b
error: Failed dependencies:
        alsa-kmdl-1.0.14-57_rc2.fc6.at is needed by
alsa-driver-1.0.14-57_rc2.fc6.at.i386

Comment 11 Craig Lister 2007-03-08 21:23:48 EST
I think that I sort of have a work-around for this problem. If after boot I go
into the sound detection applet there are, on the sound test main tab,  two tabs
listed there, nVidia - CK804 AC'97 - snd-intel8x0 and PNPb006 - PNPb006 -
mpu401. No amount of sound testing here yields any result. If I then go to the
main System tab and hit 'Reload audio drivers' it says that they cannot be
reloaded and to re-boot.

If, however, I load KDE and try the same procedure, I still have no sound from
either device, BUT if I go the the main tab System and hit 'Reload audio
drivers' they reload and now I have sound ???
Comment 12 Martin Stransky 2007-03-22 06:54:21 EDT
Can you please try to add these lines to your /etc/modprobe.conf?

alias snd-card-2 cx88_alsa
options cx88_alsa index=2

They should move cx88_alsa to the third position and free a slot for snd-intel8x0.
Comment 13 Craig Lister 2007-03-22 07:27:38 EDT
Ok, my modprobe.conf now looks like this :-

alias eth0 skge
alias eth1 forcedeth
alias scsi_hostadapter sata_sil
alias scsi_hostadapter1 sata_nv
alias snd-card-0 snd-intel8x0
alias snd-card-2 cx88_alsa
options cx88_alsa index=2
options snd-card-0 index=0  
options snd-intel8x0 index=0  
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias snd-card-1 snd-mpu401
options snd-card-1 index=1  
options snd-mpu401 index=1  
remove snd-mpu401 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-mpu401
Comment 14 Martin Stransky 2007-03-22 07:31:10 EDT
So does it work fine? (after reboot)
Comment 15 Craig Lister 2007-03-22 07:46:17 EDT
Yes the sound is there but it takes about 5 mins for the desktop to come up???
Comment 16 Martin Stransky 2007-05-16 09:10:18 EDT
Hm, this change makes your boot so slow?

Note You need to log in before you can comment on or make changes to this bug.