Bug 230547 - Yum seems to be broken in Rawhide
Summary: Yum seems to be broken in Rawhide
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 13:34 UTC by Daniel Walsh
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-01 18:09:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Walsh 2007-03-01 13:34:28 UTC
Description of problem:

Yum is not seeing all the files available in the repository.

For example 

When I try to update firefox

 yum -y upgrade firefox
Loading "installonlyn" plugin
Loading "skip-broken" plugin
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Running transaction check
Checking deps for firefox.i386 0-2.0.0.1-5.fc7 - None
Checking deps for firefox.i386 0-2.0.0.2-1.fc7 - u
--> Processing Dependency: gecko-libs = 1.8.1.1 for package: devhelp
--> Processing Dependency: gecko-libs = 1.8.1.1 for package: devhelp
--> Processing Dependency: gecko-libs = 1.8.1.1 for package: yelp
--> Processing Dependency: firefox = 2.0.0.1-5.fc7 for package: firefox-devel
--> Finished Dependency Resolution
Error: Missing Dependency: firefox = 2.0.0.1-5.fc7 is needed by package
firefox-devel

I get a denial for because there is no update for firefox-devel

If I just list firefox-devel, you reports that there is no available packages
for firefox-devel

 yum -y list firefox firefox-devel
Loading "installonlyn" plugin
Loading "skip-broken" plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
firefox.i386                             2.0.0.1-5.fc7          installed       
firefox-devel.i386                       2.0.0.1-5.fc7          installed       
Available Packages
firefox.i386                             2.0.0.2-1.fc7          development  

This is happening all over rawhide, and I am not able to update.

Comment 1 Jeremy Katz 2007-03-01 16:44:34 UTC
Which rawhide tree is this pointing against?  Yesterday had only partial metadata...

Comment 2 Daniel Walsh 2007-03-01 18:09:52 UTC
Ok works today.


Note You need to log in before you can comment on or make changes to this bug.