Bug 23059 - g++ output bad assembler code.
Summary: g++ output bad assembler code.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL: http://cvs.sourceforge.net/cgi-bin/cv...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-31 17:34 UTC by Fred Wittekind IV
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-31 17:35:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fred Wittekind IV 2000-12-31 17:34:59 UTC
gcc version 2.96 20000731 (Red Hat Linux 7.0)

g++ -c -o out/LINUX/INTEL/optimize/scan16.o
plugins/video/renderer/software/scan16.cpp -Wall -Wunused -W -mpentium
-march=i586 -fno-exceptions -fno-rtti -O6 -fomit-frame-pointer
-ffast-math   -I. -I./apps -I./include -I./libs -I./plugins -I./support
/tmp/ccAGBrAJ.s: Assembler messages:
/tmp/ccAGBrAJ.s:17617: Error: local label "6" (instance number 1 of a fb
label)
is not defined

Don't know if this is just a change in GCC producing a bug in existing
code, or if some existing code triggered a bug in GCC.

Above URL maps to the sourceforge respository that contains the version of
the file I used.

Comment 1 Jakub Jelinek 2001-01-02 11:08:34 UTC
That's a bug in the plugin, particularly in
plugins/video/renderer/software/scanln.inc I think.
Since gcc supports multiple assembly dialects on ia32 (AT&T and Intel syntax),
| is a special character in asm patterns which separates the dialects.
Just remove | from comments in inline mmx assembly and things will compile
just fine.


Note You need to log in before you can comment on or make changes to this bug.