Bug 230662 - Faulty text-wrapping for Asian languages
Faulty text-wrapping for Asian languages
Product: Fedora
Classification: Fedora
Component: xchat-gnome (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2007-03-01 18:08 EST by Debarshi Ray
Modified: 2014-03-16 23:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-12-14 18:13:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Tarball containing screenshots showing the bug. (681.58 KB, application/x-bzip)
2007-03-01 18:08 EST, Debarshi Ray
no flags Details
Screenshot of attempt to duplicate bug (115.56 KB, image/png)
2007-03-01 20:00 EST, Brian Pepple
no flags Details
Screenshot of the bug in Fedora 8 (172.75 KB, image/png)
2008-05-08 22:51 EDT, Debarshi Ray
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 423105 None None None Never

  None (edit)
Description Debarshi Ray 2007-03-01 18:08:58 EST
Description of problem:

When a line goes beyond the breadth of the text window, the last word (or couple
of words) get partially or completely hidden behind the right handside
scrollbar. Subsequent words continue on the next line.

Version-Release number of selected component (if applicable):

xchat-gnome 0.16-11

How reproducible:
Every time the length of a sentence is more than the breadth of the text window.
Both when the xchat-gnome window is maximized and unmaximized.

Steps to Reproduce:

1. Open Xchat-GNOME, and join any channel on any network.
2. Start typing. Make sure that the sentence is longer than the width of the
input box.
3. Hit enter, and see the sentence you just typed appear in the channel text window.

Actual results:

The words which were lying on the border of the text window did not get wrapped
around completely onto the next line. They instead got hidden behind the
right-hand side scroll bar. Subsequent words appeared on the next line.

Expected results:

One would expect the whole word to be wrapped appear on the following line, and
not get visually contatenated beyond the window margins.

Additional info:

Here is a tarball containing a couple of screenshots:

Here are the individual screenshots:
a. http://glug-nith.org/~rishi/download/xchat-gnome/xchat-gnome1.png
(unmaximized window)
b. http://glug-nith.org/~rishi/download/xchat-gnome/xchat-gnome2.png (maximized
Comment 1 Debarshi Ray 2007-03-01 18:08:58 EST
Created attachment 149068 [details]
Tarball containing screenshots showing the bug.
Comment 2 Brian Pepple 2007-03-01 20:00:14 EST
Created attachment 149078 [details]
Screenshot of attempt to duplicate bug

Hmmm, I tried to duplicate this bug, but was unable to get the same behavior
you had.
Comment 3 Debarshi Ray 2007-03-02 03:25:17 EST
> Hmmm, I tried to duplicate this bug, but was unable to get the same behavior
> you had.

Well that is because you are using a different language than me! My default
language is "Bengali (India)". I tried it out after setting my language to
"American English" and logging back in. The problem was not present.

In case you are interested, I tried this string: "This is a check to see
investigate the text-wrapping problem in XChat-GNOME 0.16. I have a hunch that
this problem is not present in a American English Desktop."

Before jumping to any conclusion, I would like to try it out under a few
different languages as well.
Comment 4 Debarshi Ray 2007-03-02 04:46:57 EST
Let me re-write the steps to re-produce the bug:

a. Log into Fedora Core 6 GNOME desktop, using your favourite language setting.

b. Run XChat-GNOME as:
   $ LANG=bn_IN.UTF-8 /usr/bin/xchat-gnome

c. Go to Preferences -> Setting, ie. the last entry on the second main menu
option in XChat-GNOME. Select the font to be used as either "Use system terminal
font", or select "Monospace" from the drop-down menu.

d. Now start typing a message in the text input box. The message can be in
English too. Make sure that the text is longer than the width of the window as
mentioned in the original bug-report.

e. One can notice that the message is not wrapped around properly (see
screenshots in the original report) at the right-hand edges of the channel
conversation window.

f. The problem is not present if some other font, say Bitstream Vera Sans Mono,
is selected keeping LANG=bn_IN.UTF-8.

This problem is not noticed for other values of LANG.
Comment 5 Jens Petersen 2007-05-31 04:16:02 EDT
I see this too in a Japanese locale (ie ja_JP.UTF-8).
Comment 6 Bug Zapper 2008-04-04 02:24:40 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 7 Jens Petersen 2008-04-04 04:48:43 EDT
Better to attacj screenshots in bugzilla in future if possible.

I can't reproduce this any longer under current rawhide (pre-F9).
I tested with xchat-gnome-0.18-12.fc9 in Japanese.
Comment 8 Jens Petersen 2008-04-04 05:06:01 EDT
(AFAICR it still happened under F8)
Comment 9 Debarshi Ray 2008-05-08 22:51:12 EDT
Created attachment 304920 [details]
Screenshot of the bug in Fedora 8

It still occurs in xchat-gnome-0.18-9.fc8. If you look at the right margin of
the attached screenshot, you will notice that some of the words did not wrapped
and instead portions of them got hidden beyond the margin.
Comment 10 Jens Petersen 2008-05-08 23:04:43 EDT
Right, I suspect the reason it works in F9 is probably due to changes in pango.
So this bug should probably be moved to there.
Comment 11 Behdad Esfahbod 2008-05-09 03:39:45 EDT
Unless it is can be reproduced in gedit or pidgin, it's a xchat-gnome bug. 
Throwing back.
Comment 12 Jens Petersen 2008-05-11 21:00:13 EDT
(In reply to comment #11)
> Unless it is can be reproduced in gedit or pidgin, it's a xchat-gnome bug. 

Well the point is it is fixed in F9 and the current version of xchat-gnome in F8
is the same... so it can't be xchat-gnome?  I still suspect pango or maybe some
fontconfig changes?  Perhaps we should just close it nextrelease? ;)
Comment 13 Jens Petersen 2008-05-11 21:01:49 EDT
(I think the same is true for xchat (bug 132527).)
Comment 14 Jens Petersen 2008-05-22 02:12:25 EDT
Actually I was wrong: well it seems ok for Japanese for me,
but in Chinese locale zh_CN.UTF-8 I still see the problem.
Comment 15 Tony Fu 2008-09-09 23:11:21 EDT
requested by Jens Petersen (#27995)
Comment 16 Bug Zapper 2009-06-09 18:29:12 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 17 Jens Petersen 2009-06-23 01:38:06 EDT
still happening
Comment 18 Runa Bhattacharjee 2009-10-30 00:01:39 EDT
Tested for xchat-gnome-0.26.1-5.fc12 and the bug still exists.
Comment 19 Bug Zapper 2009-11-16 02:54:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
Comment 20 fujiwara 2010-04-21 02:03:30 EDT

Hmm.., xchat-gnome(i.e. gtk_xtext_*) may need to be rewritten.
Comment 21 Bug Zapper 2010-07-30 06:29:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
Comment 22 Akira TAGOH 2011-12-05 06:28:26 EST
Does this still persist on f16 say?
Comment 23 Bill Nottingham 2011-12-14 18:13:55 EST
Presumably - the upstream bug is still open.

I'm closing this as 'UPSTREAM' for now, as I personally do not have the time to work on this fix myself - I'm at the mercy of upstream for it. I've CC'd myself on the upstream bug, so when it gets fixed, I can pull it into Fedora.

Note You need to log in before you can comment on or make changes to this bug.