Bug 23070 - RH7 installer crashes after Anaconda starts, line 33
RH7 installer crashes after Anaconda starts, line 33
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-01 06:08 EST by Deviate
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 18:13:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deviate 2001-01-01 06:08:51 EST
1st, happy newyear!

ok here goes. I am trying to install RH7 on an IBM thinkpad 390, 32 Mb 
RAM, 3Gb HD (of which 1,2 for a win98 partition), USB ZIPCD (iomega) 
Parallel ZIP100 (iomega), PCMCIA Sitecom 10/100 Mbit FastEthernet card, 
Neomagic 256AV sound/videocard. 
I downloaded the RH7.0 iso from a mirror, burned it. inserted, rebooted.
the startupscreen asked me if I want to install in graphic/text/expert etc 
mode. usually I choose text, but all of the modes show the same problem.

The kernel decompresses, nice and fast, detection of hardware goes 
smoothly, untill this message pops up:

Running anaconda, this may take some time
file "usr/bin/anaconda", line 33
   syslog = Syslogd (root, new Object
                                    ^
Syntax Error: invalid syntax
install exited abnormally
sending termination signals...done
sending kill signals...done
unmounting filesystems...
/proc/bus/usb
/mnt/runtime
/mnt/source umount failed (16)
/dev/pts
/proc
You may safely reboot.

Bummer.
Thinking maybe the image was corrupted in some way, I downloaded the image 
from a different mirror. Also tried the image that said 'RH7respin'
 (whatever that may be, is it an update?)

Same problem. I then pulled out the RedHat 6.2 Professional which I bought 
sometime earlier, and inserted that. 
The installer works fine, and RedHat 6.2 installs smoothly.

I could try the RH7upgrade ISO, but that doesn't solve the problem.
Unfortunately, I have no other systems available to try the installer on.

Thanks for taking the trouble to look into this,
kind regards,
Michiel van Mil
dv8@home.nl
Comment 1 Michael Fulbright 2001-01-03 18:13:32 EST
That line should read:

	syslog = Syslogd (root, open (output, "w+"))

It looks like your files are corrupted.

Note You need to log in before you can comment on or make changes to this bug.