Bug 230746 - Lock Screen hangs desktop if rdesktop has focus
Lock Screen hangs desktop if rdesktop has focus
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 12:11 EST by Leon Stringer
Modified: 2008-03-18 14:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:41:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leon Stringer 2007-03-02 12:11:02 EST
Description of problem:
If you lock the screen when rdesktop has the focus and the mouse cursor is
within this window then either the lock doesn't occur or the lock doesn't appear
but nothing works on the desktop, except the rdesktop session which can be
operated by the keyboard only.

Version-Release number of selected component (if applicable):
2.16.1-4

How reproducible:
Fairly consistent

Steps to Reproduce:
1. Start an rdesktop session, connecting it to a Windows terminal server.
2. With the rdesktop window active, open the System menu at the top.
3. Select Lock Screen while the mouse is in the rdesktop client area. This can
be achieved in two ways:
  a. If the rdesktop window fills your desktop (such that the Lock Screen menu
item obscures the rdesktop window).
  b. Move the mouse cursor to the rdesktop window and activate the Lock Screen
menu item by pressing return.
  
Actual results:
Either the Lock Screen isn't activated or, nothing appears to happen, then when
you try to click on items on the desktop (other applications, GNOME system menu,
etc.) nothing happens (menu bar items highlight but do not drop down). With the
rdesktop window active, you can close this with the keyboard (Ctrl+Alt+Del). The
only option with the GNOME desktop is Ctrl+Alt+BkSp and start again.

Expected results:
Lock Screen starts normally.

Additional info:
Comment 1 jmccann 2007-03-02 12:26:02 EST
rdesktop grabs the keyboard while it has focus [1].  But g-s tries to nuke the
focus before it grabs the keyboard.  Last I checked this was working ok with
2.16.1.  Can you file a bug upstream (bugzilla.gnome.org) and include a debug
log when this occurs [2]?

Thanks.

[1] http://rdesktop.cvs.sourceforge.net/rdesktop/rdesktop/xwin.c?view=markup
[2]
http://live.gnome.org/GnomeScreensaver/FrequentlyAskedQuestions#head-d50bc17e7d6f3a51c4715f02c657195e80e26c2c
Comment 2 Leon Stringer 2007-03-05 10:08:32 EST
I don't think I can. There only seems to be an RPM for
gnome-screensaver-debuginfo-2.16.0-7, but the main package is
gnome-screensaver-2.16.1-4 so there's no match. If I "run gnome-screensaver
--no-daemon --debug" the problem doesn't occur in quite the same way (the screen
doesn't go blank until you move the mouse, but when it does you can unlock it in
the normal way).
Comment 3 Ray Strode [halfline] 2008-03-18 14:41:07 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.