Bug 230768 - dosbox 0.70 released
dosbox 0.70 released
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dosbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 14:21 EST by Christopher Stone
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-04 17:42:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2007-03-02 14:21:48 EST
dosbox 0.70 has been released.
Comment 1 Christopher Stone 2007-03-03 19:37:54 EST
There are also some problems with the spec file:

1) --enable-shots is not a recognized configure option
2) dosbox should be configured with --enable-core-inline
3) you should use make install DESTDIR=$RPM_BUILD_ROOT (%makeinstall should be
avoided whenever possible)
Comment 2 Andreas Bierfert 2007-03-04 05:30:11 EST
Thanks for reporting, I will take a look at it now.

1) and 2) sound good to me. However what you say about %makeinstall is not how I
think about it an in this case was taken by choice and not by accident...
Comment 3 Christopher Stone 2007-03-04 12:38:25 EST
From the packaging guidelines page:
http://fedoraproject.org/wiki/Packaging/Guidelines#head-fcaf3e6fcbd51194a5d0dbcfbdd2fcb7791dd002

Fedora's RPM includes a %makeinstall macro but it must NOT be used when make
install DESTDIR=%{buildroot} works.

I tested the make install DESTDIR=$RPM_BUILD_ROOT and it works fine, therefore
%makeinstall should be avoided at all costs because it is a kludge.  Please read
the link above for more information.
Comment 4 Andreas Bierfert 2007-03-04 17:42:09 EST
Thanks for the lesson ;) I still don't see the point anyway but you are right in
current version (and actually in the 0.65) make install works and as you may see
from the commits earlier I changed it so I hope you are happy :). Thanks again
for submitting the bug. 

Note You need to log in before you can comment on or make changes to this bug.