Bug 230809 - Need /usr/lib/libgnat.so
Need /usr/lib/libgnat.so
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 19:06 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-03 02:48:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-03-02 19:06:00 EST
Description of problem:

gcc-gnat 4.1.1 on FC6 provides /usr/lib/libgnat.so.  It doesn't in development.
 Is this intentional?  Perhaps we need a libgnat-devel?

Version-Release number of selected component (if applicable):
4.1.2-3
Comment 1 Jakub Jelinek 2007-03-03 02:48:07 EST
That's not true, FC6 doesn't have /usr/lib{,64}/libgnat.so either, and
intentionally not so.  libgnag.so symlink is in gcc-gnat package, in
/usr/lib/gcc/*/4.1.*/adalib/, because it is inherently gcc version dependent.
If you use the right tools to build Ada programs (see info gnat, e.g. gnatmake
etc.) it will work just fine.

Note You need to log in before you can comment on or make changes to this bug.