Bug 230877 - pirut crashes after installing any package
pirut crashes after installing any package
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 230887 230923 232851 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-03-03 23:42 EST by petrosyan
Modified: 2010-12-06 09:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 17:54:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First Crashdump of Package Manager pirut 1.3.2-1.fc7 (1.01 KB, application/octet-stream)
2007-03-10 12:24 EST, Bryan L. Gay
no flags Details
Second crashdump of Package Manager (1.01 KB, application/octet-stream)
2007-03-10 12:26 EST, Bryan L. Gay
no flags Details

  None (edit)
Description petrosyan 2007-03-03 23:42:51 EST
Description of problem:
After installing dejavu-fonts pirut crashed. Traceback included.

Version-Release number of selected component (if applicable):
pirut-1.3.3-1.fc7

Additional info:

Component: Software Manager
Summary: TB8c4c1afd __init__.py:477:_getGroups:GroupsError: No Groups Available
in any repository

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 114, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 290, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 446, in
doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 504, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 477, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
repo: extras-development
self: <__main__.PackageManager object at 0x9906eec>
reposWithGroups: [<yum.yumRepo.YumRepository object at 0x991c7cc>,
<yum.yumRepo.YumRepository object at 0x993724c>]
overwrite: False
Comment 1 Jeremy Katz 2007-03-05 15:13:51 EST
What mirrors are you pointing at?  Does this still occur?  This shouldn't happen
as at least the core repo should have a comps file (and extras as well)
Comment 2 Jeremy Katz 2007-03-05 15:14:43 EST
*** Bug 230923 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2007-03-05 15:14:50 EST
*** Bug 230887 has been marked as a duplicate of this bug. ***
Comment 4 petrosyan 2007-03-05 16:38:53 EST
I am using the default yum repositories:
[development]
name=Fedora Core - Development
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$ba
search/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basear
ch
enabled=1
gpgcheck=0
[extras-development]
name=Fedora Extras - Development Tree
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/development/$
basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-devel&arch=$b
asearch
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-extras
gpgcheck=1

This bug is 100% reproducible, and it happens when installing any new package.
Here is a terminal output when installing 'wget':
# pirut
Loading "installonlyn" plugin
Repository development is listed more than once in the configuration
Repository core is listed more than once in the configuration
Repository legacy-updates is listed more than once in the configuration
Repository extras-source is listed more than once in the configuration
Repository updates-debuginfo is listed more than once in the configuration
Repository development-debuginfo is listed more than once in the configuration
Repository core-source is listed more than once in the configuration
Repository extras-development is listed more than once in the configuration
Repository extras-development-source is listed more than once in the configuration
Repository updates-testing-debuginfo is listed more than once in the configuration
Repository updates-source is listed more than once in the configuration
Repository extras-development-debuginfo is listed more than once in the
configuration
Repository updates-testing is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository updates-testing-source is listed more than once in the configuration
Repository legacy-testing is listed more than once in the configuration
Repository development-source is listed more than once in the configuration
Repository extras-debuginfo is listed more than once in the configuration
Repository core-debuginfo is listed more than once in the configuration
Checking deps for wget.i386 0-1.10.2-15.fc7 - u
Component: Software Manager
Summary: TB8c4c1afd __init__.py:477:_getGroups:GroupsError: No Groups Available
in any repository

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 114, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 290, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 446, in
doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 504, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 477, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
repo: extras-development
self: <__main__.PackageManager object at 0x8e5ef2c>
reposWithGroups: [<yum.yumRepo.YumRepository object at 0x8e7480c>,
<yum.yumRepo.YumRepository object at 0x8e8f28c>]
overwrite: False
Comment 5 Chitlesh GOORAH 2007-03-08 14:29:14 EST
Hello there,
I've encountered the same bug and at the same time, some icons are missing on pirut.

/usr/lib/python2.5/site-packages/rhpl/exception.py:357: GtkWarning: Error
loading theme icon for stock: Image file
'/usr/share/icons/Echo/48x48/actions/gtk-find.png' contains no data
  gtk.STOCK_OPEN, gtk.RESPONSE_OK))
/usr/lib/python2.5/site-packages/rhpl/exception.py:357: GtkWarning: Error
loading theme icon for stock: Image file
'/usr/share/icons/Echo/48x48/devices/gtk-harddisk.png' contains no data
  gtk.STOCK_OPEN, gtk.RESPONSE_OK))
/usr/lib/python2.5/site-packages/rhpl/exception.py:357: GtkWarning: Error
loading theme icon for stock: Image file
'/usr/share/icons/Echo/24x24/actions/gtk-add.png' contains no data
  gtk.STOCK_OPEN, gtk.RESPONSE_OK))
/usr/lib/python2.5/site-packages/rhpl/exception.py:357: GtkWarning: Error
loading theme icon for stock: Image file
'/usr/share/icons/Echo/24x24/actions/gtk-remove.png' contains no data
  gtk.STOCK_OPEN, gtk.RESPONSE_OK))
/usr/lib/python2.5/site-packages/rhpl/exception.py:359: GtkWarning: Error
loading theme icon for stock: Image file
'/usr/share/icons/Echo/24x24/actions/gtk-open.png' contains no data
  rc = d.run()
/usr/lib/python2.5/site-packages/rhpl/exception.py:359: GtkWarning: Error
loading theme icon for stock: Image file
'/usr/share/icons/Echo/24x24/actions/gtk-cancel.png' contains no data
  rc = d.run()

Component: Software Manager
Summary: TB8c4c1afd __init__.py:477:_getGroups:GroupsError: No Groups Available
in any repository

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 114, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 290, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 446, in
doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 504, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 477, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
GroupsError: No Groups Available in any repository

Local variables in innermost frame:
repo: development
self: <__main__.PackageManager object at 0x952912c>
reposWithGroups: [<yum.yumRepo.YumRepository object at 0x959524c>,
<yum.yumRepo.YumRepository object at 0x954d90c>]
overwrite: False

[root@gatux ~]# rpm -q echo-icon-theme
echo-icon-theme-0.2-0.20070223wiki.fc7

[root@gatux ~]# rpm -q pirut
pirut-1.3.3-1.fc7
Comment 6 Bryan L. Gay 2007-03-10 12:24:01 EST
Created attachment 149778 [details]
First Crashdump of Package Manager pirut 1.3.2-1.fc7

First run of Package Manager to install airsnort, et al
Comment 7 Bryan L. Gay 2007-03-10 12:26:03 EST
Created attachment 149779 [details]
Second crashdump of Package Manager

Second run of Package Manager to install thunderbird
Comment 8 Jeremy Katz 2007-03-19 17:54:19 EDT
Okay, tracked this down to a bug in yum.  Fixed upstream and will be in 3.1.5
Comment 9 Jeremy Katz 2007-03-19 23:12:21 EDT
*** Bug 232851 has been marked as a duplicate of this bug. ***
Comment 10 das_deniz 2007-03-24 11:06:28 EDT
confirmed fix with yum-3.1.5-1.fc7 and pirut-1.3.4-1.fc7 thank you!
Comment 11 Juan Ricardo 2010-12-06 09:57:33 EST
(In reply to comment #0)
> Description of problem:
> After installing dejavu-fonts pirut crashed. Traceback included.
> 
> Version-Release number of selected component (if applicable):
> pirut-1.3.3-1.fc7
> 
> Additional info:
> 
> Component: Software Manager
> Summary: TB8c4c1afd __init__.py:477:_getGroups:GroupsError: No Groups Available
> in any repository
> 
> Traceback (most recent call last):
>   File "/usr/sbin/pirut", line 114, in _pageSwitch
>     self.pageMap[num]()
>   File "/usr/sbin/pirut", line 290, in _showBrowse
>     grpsel.doRefresh()
>   File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 446, in
> doRefresh
>     if len(self.ayum.comps.categories) == 0:
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 504, in <lambda>
>     comps = property(fget=lambda self: self._getGroups(),
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 477, in _getGroups
>     raise Errors.GroupsError, 'No Groups Available in any repository'
> GroupsError: No Groups Available in any repository
> 
> Local variables in innermost frame:
> repo: extras-development
> self: <__main__.PackageManager object at 0x9906eec>
> reposWithGroups: [<yum.yumRepo.YumRepository object at 0x991c7cc>,
> <yum.yumRepo.YumRepository object at 0x993724c>]
> overwrite: False

Note You need to log in before you can comment on or make changes to this bug.