Bug 230899 - Error in the man-pages.spec file: incorrect encoding convertation
Summary: Error in the man-pages.spec file: incorrect encoding convertation
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: man-pages   
(Show other bugs)
Version: rawhide
Hardware: All
OS: All
medium
low
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-04 14:12 UTC by Dmitry S. Vasilchenko
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-16 12:52:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dmitry S. Vasilchenko 2007-03-04 14:12:44 UTC
man-pages 2.43-8 fc7 and earlier

The following lines in the man-pages.spec file possibly contain an error:

       LANG=en iconv -f latin1 -t utf-8 -o en/$l1 $l1
       rm -f $l1
       LANG=en iconv -f latin1 -t ascii//translit -o $l1 en/$l1

Specifically, the third line should supply "-f utf-8" to the iconv utility 
since a man-page on input is in the UTF8 encoding. Any thoughts, is this an 
error?

Comment 1 Ivana Varekova 2007-03-16 12:52:13 UTC
Thanks.
Fixed in man-pages-2.43-11.fc7.


Note You need to log in before you can comment on or make changes to this bug.