Bug 230916 - updates feature doesn't work with floppy
updates feature doesn't work with floppy
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: David Lehman
: Reopened
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-03-04 13:16 EST by Bruno Wolff III
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 14:24:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2007-03-04 13:16:29 EST
Description of problem:
I tried using the updates feature of anaconda using the instructions at:
http://fedoraproject.org/wiki/Anaconda/Updates
but it didn't work with a floppy.
I was able to mount the floppy on fc5 and see the replacement raid.py file listed.
When I was attempting to install using rawhide from a couple of days ago, I
would get prompted for the device to get updates from and select fd0. But this
would fail. It did get far enough into the boot process to have access to a
shell prompt and I couldn't get the floppy to mount there either. So this may
really be only tenuously connected to anaconda. I tried mounting with no -t
option and specifying ext2, ext3, and ext and none of these worked.

Version-Release number of selected component (if applicable):
11.2.0.28-1

How reproducible:
100%

Steps to Reproduce:
1. Follow instructions at http://fedoraproject.org/wiki/Anaconda/Updates to
create floppy.
2. Use tab to edit options and add "updates"
3. Select fd0 as device to get updates from
  
Actual results:
Selecting fd0 fails


Expected results:
Install continues using updates from fd0


Additional info:
Comment 1 Jeremy Katz 2007-03-05 15:43:48 EST
Looks like the support for cpio balls as updates.img broke filesystem images
Comment 2 David Lehman 2007-03-05 21:35:58 EST
I verified that ext2 updates.img worked before I committed the cpio ball patch.
If this turns out to not be a dupe of 230946 we can just reopen it.

*** This bug has been marked as a duplicate of 230946 ***
Comment 3 Bruno Wolff III 2007-03-08 14:30:04 EST
I am still seeing the boot with this morning's boot.iso.
Also I tried using an msdos file system instead of ext2 and that didn't work for
the updates, but I was able to mount it manually from a shell prompt while the X
window was prompting for the device containing the updates. I was still not able
to mount ext2 floppies at this point in the install process.
Comment 4 Bruno Wolff III 2007-03-12 14:24:57 EDT
This works with today's boot.iso.

Note You need to log in before you can comment on or make changes to this bug.