Bug 230936 - after a while terminal isn't updated
after a while terminal isn't updated
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
http://bugzilla.gnome.org/show_bug.cg...
:
: 231515 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-03-04 15:39 EST by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 12:13:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2007-03-04 15:39:34 EST
Description of problem:
If you leave gnome-terminal for a while it will stop updating, so you can type
away and nothing will be shown in your terminal, restarting gnome-terminal
restores working order for a while. This may be related to the vte-0.15.6-1.fc7
update as the error appeared around the same time.

Version-Release number of selected component (if applicable):
vte-0.15.6-1.fc7
gnome-terminal-2.17.92-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. Start gnome-terminal, do something say yum update
2. wait
3. go back to your terminal
  
Actual results:
Typing resultings in no visual feedback

Expected results:
Perfect working order

Additional info:
Comment 1 Matthew Miller 2007-03-08 13:12:37 EST
Ditto here.

I also tested with Terminal, from Fedora Extras -- a different program also
using vte. That exhibits the same behavior. So I think this should probably be
moved to vte.
Comment 2 Matthew Miller 2007-03-08 13:21:35 EST
And here's the upstream bug:
Comment 3 Matthew Miller 2007-03-08 13:22:59 EST
Sorry for the triple comment -- in that bug, the trigger is switching desktops.
And indeed, that certainly sets it off for me. I can't promise that's the only
case I'm seeing it, though. David, what about you?
Comment 4 David Nielsen 2007-03-08 13:42:51 EST
doesn't seem to do the trick here but repeatedly minimizing gnome-terminal tends
to make gnome-terminal crash without getting catched by bug-buddy (though I
think that's another bug I seem to recall someone on f-d-l reporting issues like
that a few days ago).



Comment 5 Deji Akingunola 2007-03-08 14:06:17 EST
switching desktops triggers it for me too.
Comment 6 Behdad Esfahbod 2007-03-12 19:40:38 EDT
Is this with compiz enabled?  Does it still happen with latest vte in rawhide?
Please move the discussion upstream so we can get this fixed.
Comment 7 Behdad Esfahbod 2007-03-12 19:45:16 EDT
*** Bug 231515 has been marked as a duplicate of this bug. ***
Comment 8 David Nielsen 2007-03-12 21:11:02 EDT
This only appear to happen with Compiz enabled yes, the version of vte installed
is vte-0.15.6-1.fc7
Comment 9 Matthew Miller 2007-03-12 21:12:37 EDT
Hmmm. Not sure why bugzilla threw away my reference to the upstream bug in
comment #2. Let me try again: http://bugzilla.gnome.org/show_bug.cgi?id=414716
Comment 10 Matthew Miller 2007-03-12 21:19:42 EDT
I'm using metacity -- compiz isn't enabled. At least, I'm pretty sure -- I'll
have to check at work tomorrow. (I can't remember how to just ask gconf to tell
me in an ssh window. Grr.)

Behdad -- are you expecting a version in rawhide other than the vte-0.15.6-1.fc7
listed above and which is what I see in the tree right now? Because as far as I
know, that's where the issue *started*.
Comment 11 Behdad Esfahbod 2007-03-12 21:29:48 EDT
Building vte 0.16.0 for rawhide right now.  The upstream bug says that it should
fix this bug.
Comment 12 Deji Akingunola 2007-03-13 11:50:58 EDT
The situation is now kind of worse after updating to vte-0.16.0-1.fc7. Before
now, if I open multiple tabs in gnome-terminal, this issue will cause commands
entered  at the prompt not to be shown (usually after switching desktops), but
the screen is not cleared and commands typed could be seen by moving another
window across the terminal screen, or changing tabs. With the latest vte, if i
open multiple tabs and switch desktops, only the active tab retain its contents,
all the other tabs are totally cleared (blank). Switching tabs or moving other
windows over it doesn't change anything. 
Comment 13 Deji Akingunola 2007-03-13 11:52:45 EDT
I should state i'm using metacity on x86_64.
Comment 14 Adam Tkac 2007-03-14 08:10:41 EDT
(In reply to comment #12)
Confirmed. I build latest vte from CVS and have same problems.
Comment 16 Adam Tkac 2007-03-23 03:19:07 EDT
I have rawhide from 16th March with vte-0.16.0-1.fc7 and problem no longer
exists.  But when I build vte separately and install it problem exists. This
looks one of the "mysterious fixes"

-A-
Comment 17 Matthias Clasen 2007-04-02 02:36:33 EDT
Is any of the reporters still seeing the problem with current rawhide ?
Comment 18 Matthew Miller 2007-04-02 07:16:00 EDT
Seems okay to me. I'm a bit concerned about comment #16, though.
Comment 19 Deji Akingunola 2007-04-02 09:43:42 EDT
The problem is gone for me too.
Comment 20 Matthias Clasen 2007-04-02 12:13:22 EDT
Thanks, closing this bug then.

Note You need to log in before you can comment on or make changes to this bug.