Bug 230943 - anaconda doesn't warn you about the minimum space requeried for each partition
anaconda doesn't warn you about the minimum space requeried for each partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 236656 (view as bug list)
Depends On:
Blocks: Fedora7LiveCD
  Show dependency treegraph
 
Reported: 2007-03-04 18:15 EST by William Lovaton
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 18:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Lovaton 2007-03-04 18:15:22 EST
Description of problem:
I've been using LVM for my home machine since FC5 and I alway used a
configuration like this:
/boot  -> 100 MB
LVHome -> 4096 MB
LVOpt  -> 384 MB
LVRoot -> 640 MB
LVTmp  -> 640 MB
LVUsr  -> 8192 MB
LVVar  -> 2048 MB
LVSwap -> 512 MB

The LiveCD fails during installation of packages because there is no enough
space in the / partition (LVRoot).  Note that it used to work fine with FC5 and FC6.

I tried several times until I managed to carry the installation process to 100%
with an LVRoot of 3.5 GB.  However it failed during the post-install phase with
and error that was impossible for me to understand.

Finally I had to use the following partition setup to make the whole
installation work:
/boot  -> 100 MB
LVHome -> 4096 MB
LVRoot -> 15.38 GB
LVSwap -> 512 MB

I wonder why the LiveCD needs such a huge space in the / partition (> 3 GB) just
for a single CD installation??  Why anaconda doesn't warn me about the needed
space on each partition?  I guess the checking of this information shouldn't be
that hard to implement.


Version-Release number of selected component (if applicable):
This happened installing the Fedora 7 Test 2 Live CD.


How reproducible:
Always.

I guess this kind of checking is important since new users might be scared with
this problems and the feedback from bugbuddy is kind of huge and intimidating. I
consider my self and advanced linux user so I managed to get through by my self.
 I don't want new users giving up on fedora for this kind of bugs.
Comment 1 Jeremy Katz 2007-03-05 15:45:06 EST
The liveCD install is a dd of the filesystem image from the CD to the hard disk,
hence the rootfs needs to be as large as that filesystem image.  We should
definitely be checking and giving nicer feedback there.
Comment 2 William Lovaton 2007-03-05 17:46:55 EST
Thanks, I now understand why the LiveCD needs a very big root filesystem.  And
yes, I agree that some checking must be done to avoid frustrating the users.

I really think the Fedora Team is doing a superb job with Fedora 7, many
congratulations to all of you.

Cheers.
Comment 3 Jeremy Katz 2007-03-28 18:09:18 EDT
Implemented a check for this in CVS. 
Comment 4 Jeremy Katz 2007-04-16 20:30:40 EDT
*** Bug 236656 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.