Bug 230945 - anaconda doesn't let me set the mount point for vfat partitions
Summary: anaconda doesn't let me set the mount point for vfat partitions
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Fedora7LiveCD
TreeView+ depends on / blocked
 
Reported: 2007-03-04 23:32 UTC by William Lovaton
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 21:13:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description William Lovaton 2007-03-04 23:32:58 UTC
Description of problem:
Why anaconda disabled the mount point for vfat partitions in my hard disk?
previous versions of Fedora didn't do that.

After installation I checked that vfat partitions are supported since my usb
memory mounts without any problem.  So I can't see any reason for this
limitation in anaconda.

Version-Release number of selected component (if applicable):
This was from installing Fedora 7 Test 2 Live CD.

How reproducible:
In the partition tool of anaconda try to set the mount point of an existing vfat
partition.

Comment 1 Jeremy Katz 2007-03-05 20:45:38 UTC
Did you happen to try the regular install and see if it acted differently here?
 And what were you trying to mount the vfat partition as?

Comment 2 William Lovaton 2007-03-05 22:39:42 UTC
a) No, I didn't try the regular install because it's a DVD download and that's
too big right now.  Is there any regular CD image so I can just download the
first CD?

b) The anaconda GUI is very specific on what you can do, I tried to set the
mount point of /dev/sda1 (PATA subsystem, formerly hda1) in /media/winc but my
surprise was that the field was disabled (grayed out) so I couldn't write/select
a mount point.  I only had the options of leaving the partition untouched or
formatting it as ext3... I did choose the first one obviously.

I never had this specific problem with previous Fedora Core versions.

Comment 3 Jeremy Katz 2007-03-07 19:46:47 UTC
Okay, I see what's going on.  This is specific to the live CD.  Since we haven't
gone through the loader, we don't load all of the filesystem modules and thus
vfat ends up looking like an unsupported filesystem. 

Should be pretty quick to knock out once I get back from vacation.

Comment 4 Jeremy Katz 2007-03-28 21:13:43 UTC
Not an ideal fix, but committed something.  Won't be in test3, though


Note You need to log in before you can comment on or make changes to this bug.