Bug 230973 - xendomains uses non-existant lsb functions
xendomains uses non-existant lsb functions
Status: CLOSED DUPLICATE of bug 217566
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-lsb (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lawrence Lim
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 03:09 EST by Michael Best
Modified: 2014-03-25 20:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 21:48:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Best 2007-03-05 03:09:09 EST
if test -e /lib/lsb/init-functions; then
        # LSB    
        echo sourcing /lib/lsb/init-functions
        . /lib/lsb/init-functions
        echo_rc()
        {
            if test ${_RC_RV} = 0; then
                log_success_msg "  [${_SMSG[${_RC_RV}]}] "
            else
                log_failure_msg "  [${_SMSG[${_RC_RV}]}] "
            fi
        }

This stanza succeeds and then these log_success_msg and log_failure_msg do not
work.  Probably related to bug 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218989
which was closed as a duplicate of:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217566

But bug 217566 does not exist so I can't confirm that this problem has been solved.

I also saw this bug in Fedora Core 6.
Comment 1 Lawrence Lim 2007-06-17 21:48:42 EDT
Resolving this bug as a duplicate of 217566 as part of 5.1 update. Please let me
know if problem still exist later. Thanks.

*** This bug has been marked as a duplicate of 217566 ***

Note You need to log in before you can comment on or make changes to this bug.