Bug 230993 - Won't print to newly discovered printers
Won't print to newly discovered printers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
: 225143 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 08:08 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.4-5.5.17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 03:54:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-03-05 08:08:31 EST
Description of problem:
Sometimes OOo gets into a state where it will always print to the same printer
regardless of which printer it was told to use.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.4-5.5.10
gtk2-2.10.8-1.fc6

How reproducible:
Don't know.

Steps to Reproduce:
It's something like this:
1.Start openoffice.org and print a document somewhere.
2.Switch on a print server on the network.
3.Try to print to one of the printers on the new server.

Actual results:
Print comes from first printer.

Expected results:
Print comes from new printer.

Additional info:
I've seen this a couple of times now but haven't yet had chance to try to
reproduce it.
Comment 1 Tim Waugh 2007-03-06 09:16:02 EST
Okay, I managed to reproduce this with OpenOffice.org and not with Evince, so it
looks like it really is an OpenOffice.org bug here.
Comment 4 Tim Waugh 2007-03-12 11:18:20 EDT
Incidentally you do not need a separate print server to test this.

1. Start OOo writer, print a blank page to any queue (even a fictional remote
queue if you like).
2. File->Print and leave the print dialog there
3. Start system-config-printer and create a new queue (likewise, a fictional one
if you like)
4. The print dialog soon shows the new printer -- try printing to that.

Actual Result: the second job goes to the same printer as the first job.
Expected: goes to the new queue
Comment 5 Caolan McNamara 2007-03-12 11:46:04 EDT
grr, I'll have to sit down and look at this again then. It's *supposed* to find
out in 5.5.15 about printers added since it was initially launched. From the
description above this clearly isn't happening.
Comment 6 Caolan McNamara 2007-03-15 08:14:10 EDT
needs more magic, checked into openoffice.org-2.0.4-5.5.17
Comment 7 Caolan McNamara 2007-03-28 03:53:31 EDT
*** Bug 225143 has been marked as a duplicate of this bug. ***
Comment 8 Caolan McNamara 2007-03-28 03:54:35 EDT
This should work in FC-6 update 2.0.4-5.5.17
Comment 9 Hansen Tanjung 2007-03-28 06:09:37 EDT
Seems not yet resolved. I try this:
1. Start Writer
2. Create new printer
3. Open printer setup dialog, newly created printer not pickup at printer list

That's same as 2.0.4-5.5.10. Sorry I'm not test that with actual printing, but i
suspect this bug still alive because same behaviour as state above.
Comment 10 Caolan McNamara 2007-03-28 06:23:42 EDT
caolanm->mht: i.e. the new printer didn't show up in the printer dialog at all ? T

The bug I fixed (hopefully) was where the new printer shows up in the dialog,
but selecting it as the printer to use doesn't work. i.e. it still printed to
the last printer selected before the new one was added. And on my FC-6 box if I
add a (local) printer then it appears in the dialog and adding additional ones
and testing gives for me the expected results.

If the printer didn't show up in the printer dialog at all, then can you see if
the same thing happen in evince, if the same thing happens in even then your
problem lies with the gtk2 print dialog and I mis-duped your bug.
Comment 11 Hansen Tanjung 2007-03-28 07:01:33 EDT
Not at gtk2 print dialog, at 'printer setup' dialog. gtk2print dialog is fine. I
already try to printing and sorry to bother you, this bug is actually resolved.
The strange behaviour goes to 'printer setup' dialog, its didn't pickup update
list from cups but its got update when we did printing. I think this is another
bug, but very very minor bug and can be ignore ;-)

Thanks for the resolving this bug.

Note You need to log in before you can comment on or make changes to this bug.