Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: DEBUG util.py:461: No matches found for the following disable plugin patterns: local, spacewalk, versionlock DEBUG util.py:461: Error: DEBUG util.py:461: Problem: conflicting requests DEBUG util.py:461: - nothing provides web-assets-filesystem = 5-22.el10_0 needed by web-assets-devel-5-22.el10_0.noarch from build Version-Release number of selected component (if applicable): web-assets-devel-5-22.el10_0.noarch How reproducible: Always Steps to Reproduce: 1. Try to install web-assets-devel-5-22.el10_0.noarch Actual results: Fails to install as above Expected results: Installation succeeds Additional info: The package in CentOS Stream is: web-assets-filesystem-5-22.el10.noarch
Possible fix: replace Requires: web-assets-filesystem = %{version}-%{release} with Requires: web-assets-filesystem = %{version}
I see.
This was fixed by adjusting the dependency to require the exact NVR of web-assets-filesystem. https://src.fedoraproject.org/rpms/web-assets-epel/c/b4bfb13b513051cce4c81e5a1e4baf364e3fbff2?branch=epel10 However, web-assets-filesystem has been updated in appstream, so that strict NVR dependency is no longer correct. web-assets-devel will technically install, but then it causes the next update to fail. root@c10-container:~# dnf update web-assets-filesystem Last metadata expiration check: 0:13:54 ago on Mon Nov 18 02:21:23 2024. Error: Problem: problem with installed package web-assets-devel-5-22.el10_0.1.noarch - package web-assets-devel-5-22.el10_0.1.noarch from @System requires web-assets-filesystem = 5-22.el10, but none of the providers can be installed - package web-assets-devel-5-22.el10_0.1.noarch from epel requires web-assets-filesystem = 5-22.el10, but none of the providers can be installed - cannot install both web-assets-filesystem-5-23.el10.noarch from appstream and web-assets-filesystem-5-22.el10.noarch from @System - cannot install both web-assets-filesystem-5-23.el10.noarch from appstream and web-assets-filesystem-5-22.el10.noarch from appstream - cannot install the best update candidate for package web-assets-filesystem-5-22.el10.noarch (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) The same problem also exists for web-assets-httpd and web-assets-nginx, as reported by repoclosure. root@c10-container:~# dnf -q repoclosure --newest --pkg web-assets-devel --pkg web-assets-httpd --pkg web-assets-nginx package: web-assets-devel-5-22.el10_0.1.noarch from epel unresolved deps (1): web-assets-filesystem = 5-22.el10 package: web-assets-httpd-5-22.el10_0.1.noarch from epel unresolved deps (1): web-assets-filesystem = 5-22.el10 package: web-assets-nginx-5-22.el10_0.1.noarch from epel unresolved deps (1): web-assets-filesystem = 5-22.el10 Error: Repoclosure ended with unresolved dependencies (3) across 3 packages. I recommend applying the fix suggested in comment 1, changing the requires to just a matching version and ignoring the release.
We build from RHEL sources, so we need to match exact NEVR. For issues like this, please a separate bug reports.