Bug 231139 - [PATCH] gconfd-2 daemon never exits (after all user applications quit)
Summary: [PATCH] gconfd-2 daemon never exits (after all user applications quit)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: GConf2   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
low
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-06 14:28 UTC by wingc
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2007-0764
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:06:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH] ensure that gconfd shuts down after all clients exit (from GNOME CVS) (498 bytes, patch)
2007-03-06 14:28 UTC, wingc
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0764 normal SHIPPED_LIVE GConf2 bug fix update 2007-11-14 17:15:36 UTC

Description wingc 2007-03-06 14:28:29 UTC
Description of problem:

The 'gconfd-2' daemon, which is started up by applications that use GConf, never
exits after all GConf applications quit.  This bug was fixed in gconf-2.10.1.  I
have attached the patch from the GNOME source repository, which applies fine to
the version of GConf in RHEL4 (2.8.1) and I confirmed it fixes the problem.

This is mainly annoying on public access Unix systems with a large number of
users, because over time these gconf processes will pile up.

Version-Release number of selected component (if applicable):

The bug is present in the GConf2 RPM from RHEL4 (GConf2-2.8.1-1)

How reproducible:

always

Steps to Reproduce:
1. log into a machine (remotely) and run a program that uses GConf, e.g. 'gedit'
2. note that the program has spawned a 'gconfd-2' process in the background
3. quit the GConf-using program
  
Actual results:

The gconfd-2 process does not exit, but stays around forever.  (You can also
observe this effect by starting an X session with GNOME; after logout, a
'gconfd-2' process will hang around)

Expected results:

The gconfd-2 process should exit within 30 seconds of the time that the last
GConf client program has exited.

Additional info:

This bug was fixed in GNOME sources by a commit on 2005-06-13, labeled:

2005-06-13  Mark McLoughlin  <mark@skynet.ie>

	Fixes bug #306937 - gconfd-2 not shutting down when its
	no longer in use.

	* gconf/gconfd.c: (no_databases_in_use): account for the
	fact that the default database is on the global list of
	databases now too.


Currently, this change is revision 1982 to gconf/gconfd.c in the GNOME
Subversion repository for 'gconf'.


The original Bugzilla entry in GNOME CVS is here, which also contains a link to
the patch:

http://bugzilla.gnome.org/show_bug.cgi?id=306937


The patch applies fine to the version of GConf2 in RHEL4 (GConf2-2.8.1-1) and
fixes the problem there as well.  I rebuilt the GConf2 RPM including the patch
and the gconfd-2 daemon now exits correctly.

Comment 1 wingc 2007-03-06 14:28:29 UTC
Created attachment 149337 [details]
[PATCH] ensure that gconfd shuts down after all clients exit (from GNOME CVS)

Comment 2 Ray Strode [halfline] 2007-03-06 15:19:15 UTC
Adding to rhel 4.6 proposed list.

Comment 3 RHEL Product and Program Management 2007-05-09 05:56:37 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Ray Strode [halfline] 2007-07-24 15:42:26 UTC
devel ack for 4.6

Comment 5 Ray Strode [halfline] 2007-07-24 21:03:23 UTC
marking MODIFIED for QA, patch building into GConf2-2.8.1-1.el4 

Comment 9 errata-xmlrpc 2007-11-15 16:06:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0764.html



Note You need to log in before you can comment on or make changes to this bug.