Bug 231201 - anaconda and hald don't play nicely during livecd install
anaconda and hald don't play nicely during livecd install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC7Blocker Fedora7LiveCD
  Show dependency treegraph
 
Reported: 2007-03-06 14:02 EST by Jonathan Blandford
Modified: 2013-04-02 00:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 15:19:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hal-lock.1 (2.17 KB, text/plain)
2007-03-27 15:08 EDT, David Zeuthen
no flags Details

  None (edit)
Description Jonathan Blandford 2007-03-06 14:02:00 EST
I tried to do an install of the livecd image onto a removable harddrive last
night.  The installer seemed to mostly work well, but after anaconda started
partitioning disks, hald/nautilus tried to mount them which confused anaconda,
causing a traceback.  To get the install to fully work I had to disable hald
prior to running the installer.
Comment 1 David Zeuthen 2007-03-06 14:48:36 EST
(In reply to comment #0)
> To get the install to fully work I had to disable hald
> prior to running the installer.

Disabling automounting via check boxes in g-v-m's preference capplet might have
worked too. 

Anyway, hal really needs a way for apps to disable all automounters (whether
it's the GNOME or KDE one or something else) and I plan to add this feature for
0.5.9 which will hit Rawhide before Test 3. Then the installer can call into
this. Notably this is also needed for things like GParted.

I'll follow up on this bug when this mechanism lands in Rawhide.

     David
Comment 2 David Zeuthen 2007-03-25 21:42:15 EDT
Yesterday and today I wrote the code for doing this

 http://lists.freedesktop.org/archives/hal/2007-March/007764.html

Just a bit of more testing and I'll put this in Rawhide.
Comment 3 David Zeuthen 2007-03-27 01:28:15 EDT
This should now be in Rawhide as well as Test3. Here's a small example of how to
use it

http://gitweb.freedesktop.org/?p=hal.git;a=blob;hb=HEAD;f=examples/interface-locking-test.py

Btw, there's a bug with gnome-mount. It pops up a warning dialog saying

 +-------------------------------------------------------+
 | Cannot mount volume                                   |
 |                                                       |
 | Error org.freedesktop.Hal.Device.InterfaceLocked.     |
 |                                                       |
 | V Details                                             |
 |       The enclosing drive for the volume is locked    |
 +-------------------------------------------------------+

even when it's not invoked by the user. I'll fix this later (it's an easy fix).
Comment 4 David Zeuthen 2007-03-27 15:08:04 EDT
Created attachment 151065 [details]
hal-lock.1

There's also now a hal-lock(1) tool. Attaching the man page. Note that this
tool is not yet in Rawhide. I suspect things like gparted wants to use this
tool.
Comment 5 Jeremy Katz 2007-03-27 17:38:45 EDT
Okay, committed bits to anaconda CVS so that we'll use hal-lock if it's present.
 Needs a little testing once all the bits are in place, but I'll try to test as
is tomorrow
Comment 6 Jeremy Katz 2007-04-02 15:19:22 EDT
And tested now.  So this should be good tomorrow

Note You need to log in before you can comment on or make changes to this bug.