Bug 231244 - Multipath command execution against HP-X128 LUNs results in displaying of errors.
Multipath command execution against HP-X128 LUNs results in displaying of err...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Marzinski
Corey Marthaler
: OtherQA
Depends On:
Blocks: 234547
  Show dependency treegraph
 
Reported: 2007-03-06 17:56 EST by Issue Tracker
Modified: 2010-10-22 09:34 EDT (History)
13 users (show)

See Also:
Fixed In Version: RHEA-2007-0808
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:15:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (603 bytes, patch)
2007-03-06 18:09 EST, David Milburn
no flags Details | Diff

  None (edit)
Description Issue Tracker 2007-03-06 17:56:56 EST
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2007-03-06 17:57:22 EST
LTC Owner is: kcs@us.ibm.com
LTC Originator is: AVenkat@us.ibm.com

---Problem Description---
RHEL4-U5-Beta:20070220: "multipath" command (multipath) against HP-X128 LUNs
results in error message (error: /sbin/scsi_id -g -u -s /block/sdk).
 
Contact Information = avenkat@us.ibm.com
 
---Additional Hardware Info---
The pSeries server is attached to a HP-X128 SAN storage system thru a
McData/Brocade system.  Note: The error is seen not only on pSeries 9117-590,
but also with 9117-570 and other POWER5 systems.  
 
---uname output---
Linux iod3040.iodlab.austin.ibm.com 2.6.9-48.EL #1 SMP
 
Machine Type = IBM pSeries 9117-590 (lpar with 2 cpu) POWER5
 
---Steps to Reproduce---
(1) Install RHEL4U5-beta-20070220 to a POWER5 system connected to a HP-X128
storage system thru Fibre-Channel adapter.
(2) Install the device-mapper-multipath-0.4.5-16.1.RHEL4.ppc.rpm.
(3) Edit the /etc/multipath.conf to remove the HP-X128 LUN from the black-list.
(4) execute the command: multipath -F
(5) execute the command: multipath
The screen output will contain the error.
 
---Other Component Data---
Userspace tool common name: DM-MULTIPATH

The userspace tool has the following bit modes: N/A

Userspace rpm: The package needed for the multipath application: 
device-mapper-multipath-0.4.5-16.1.RHEL4.ppc.rpm, has to be installed after the
RHEL4U5-Beta installation.
 
*Additional information:

The problem is traced to the WWID_SIZE macro definition in the
multipath-tools-0.4.5.64/libmultipath/structs.h file. Increasing the size of
WWID_SIZE to 128 solves the problem.

The patch is attached for RedHat.  The change is already in the dm-multipath git.

If possible, we would like to see this change get into RHEL4_U5.
This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 115378
Comment 2 Issue Tracker 2007-03-06 17:57:37 EST
IBM,

Thanks for the patch. I will send it up for engineering to review. This
time is really really very late in the RHEL 4.5 release cycle. It would be
targetted for 4.6. If thats not acceptable and if you have a very strong
business justification as to why this should go in, then please give me the
details. But it is close to impossible right now for 4.5.

Regards,
Archana


Issue escalated to Support Engineering Group by: araghavan.
araghavan assigned to issue for IBM-LTC.
Internal Status set to 'Waiting on SEG'

This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 115378
Comment 3 Issue Tracker 2007-03-06 17:58:12 EST
----- Additional Comments From AVenkat@us.ibm.com  2007-03-06 10:25 EDT
-------
Thanks Archana for your attention on this bug.  The two most important
reasons
for the patch consideration is:

(1) Users cannot use the device-mapper-multipath module against HP-X128
SAN
system.  Especially in a heterogenous storage environment at the
enterprise
level, multipathing cannot be configured for HP-X128 LUNS.

(2) The change is already in the device-mapper GIT repository.

Let me know your input. 


This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 115378
Comment 4 Issue Tracker 2007-03-06 17:58:37 EST
Venkat,

I realize that its not possible to use device-mapper-multipath on HP-X128
SAN. But, I would like to get an idea of how many customers it affects and
if this were that important, why this was raised as a normal bug in the
first place.

Thanks for your inputs.

Regards,
Archana


This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 115378
Comment 5 David Milburn 2007-03-06 18:05:46 EST
RHEL4-U5-Beta:20070220: "multipath" command (multipath) against HP-X128 LUNs
results in error message (error: /sbin/scsi_id -g -u -s /block/sdk).

---Additional Hardware Info---
The pSeries server is attached to a HP-X128 SAN storage system thru a
McData/Brocade system.  Note: The error is seen not only on pSeries 9117-590,
but also with 9117-570 and other POWER5 systems.  
 
---uname output---
Linux 2.6.9-48.EL #1 SMP
 
Machine Type = IBM pSeries 9117-590 (lpar with 2 cpu) POWER5
 
---Steps to Reproduce---
(1) Install RHEL4U5-beta-20070220 to a POWER5 system connected to a HP-X128
storage system thru Fibre-Channel adapter.
(2) Install the device-mapper-multipath-0.4.5-16.1.RHEL4.ppc.rpm.
(3) Edit the /etc/multipath.conf to remove the HP-X128 LUN from the black-list.
(4) execute the command: multipath -F
(5) execute the command: multipath
The screen output will contain the error.
 
---Other Component Data---
Userspace tool common name: DM-MULTIPATH

The userspace tool has the following bit modes: N/A

Userspace rpm: The package needed for the multipath application: 
device-mapper-multipath-0.4.5-16.1.RHEL4.ppc.rpm, has to be installed after the
RHEL4U5-Beta installation.
 
*Additional information:

The problem is traced to the WWID_SIZE macro definition in the
multipath-tools-0.4.5.64/libmultipath/structs.h file. Increasing the size of
WWID_SIZE to 128 solves the problem.

The patch is attached for RedHat.  The change is already in the dm-multipath
git. If possible, we would like to see this change get into RHEL4_U5.

              

Comment 6 David Milburn 2007-03-06 18:09:27 EST
Created attachment 149406 [details]
Proposed patch
Comment 7 Ben Marzinski 2007-03-07 14:16:00 EST
This patch has been committed to The RHEL4 code.  It will be available in
RHEL 4.6, unless product management decides that there is a compelling reason for
putting it into 4.5.
Comment 8 Issue Tracker 2007-03-07 19:14:02 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|normal                      |high




------- Additional Comments From AVenkat@us.ibm.com  2007-03-07 19:03 EDT
-------
Archana,

 Please see your comment dated 03/06.  I understand that a number of IBM
pSeries
customers use a heterogenous SAN system environment (which includes
HP-X128
system) for their storage needs.  Unfortunately, when the multipath is
enabled,
the HP-X128 SAN system errs out and resulting in the loss of failover
mechanism.
 Practically ALL the pSeries customers whose servers are CONNECTED to
HP-X128
SANs will get affected and hence it is important to consider the patch
for
RHEL4-U5.  Also the change has gone into RHEL5.0-releases besides the fact
that
the change is in the dm-multipath-git.

  RHEL4-U5-20070220 is the first beta relase we received for pSeries
hardware
and the bug is being reported at the beta phase of the development cycle.
So the
bug was opened at that time with normal priority level. We discussed with
our
storage team about the impact and we understood that it would be really
good to
have this patch considered for the RHEL4-U5 and hence we are changing the
priority to a higher level. Let us know how it goes. 


This event sent from IssueTracker by araghavan 
 issue 115378
Comment 10 Tom Coughlan 2007-04-03 13:37:41 EDT
I'll set devel_ack, based on Ben's comment 7. This may have enough benefit, and
low enough risk, to get in 4.5.
Comment 11 Suzanne Yeghiayan 2007-04-11 18:07:15 EDT
This RHEL 4.5 proposed exception did not receive all 3 acks and thus was not
approved for 4.5.
Moved to 4.6.
Comment 12 RHEL Product and Program Management 2007-05-09 01:51:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 John Poelstra 2007-08-29 13:19:35 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 15 John Poelstra 2007-09-05 18:25:41 EDT
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 16 John Poelstra 2007-09-11 20:40:42 EDT
A fix for this issue should be included in RHEL4.6-Snapshot2--available soon on
partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 17 John Poelstra 2007-09-20 00:29:41 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6-Snapshot3 on partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 18 John Poelstra 2007-09-26 19:35:15 EDT
A fix for this issue should be included in the packages contained in
RHEL4.6-Snapshot4--available now on partners.redhat.com.  

Please verify that your issue is fixed ASAP to ensure that it is included in
this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 20 errata-xmlrpc 2007-11-15 11:15:48 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0808.html

Note You need to log in before you can comment on or make changes to this bug.