Bug 231290 - Loader received SIGSEGV! Backtrace: follows...
Loader received SIGSEGV! Backtrace: follows...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-03-07 09:51 EST by Jarod Wilson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-09 14:58:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to loader to handle loaderData->ip being NULL (1.97 KB, patch)
2007-03-08 12:35 EST, David Cantrell
no flags Details | Diff
Updated anaconda SRPM with loader patch. (3.87 MB, application/x-rpm)
2007-03-08 13:54 EST, David Cantrell
no flags Details
New initrd.img for IA64 (9.38 MB, application/octet-stream)
2007-03-08 14:35 EST, David Cantrell
no flags Details
New ramdisk.image.gz for PPC64 (6.41 MB, application/x-gzip)
2007-03-08 14:51 EST, David Cantrell
no flags Details

  None (edit)
Description Jarod Wilson 2007-03-07 09:51:15 EST
Description of problem:
Multiple attempted rawhide installs using last nights tree on an ia64 system
resulted in the following error:

loader received SIGSEGV!  Backtrace:                                           
[0x4000000000000530]
[0xa0000000000107e0]
[0x400000000032c600]
[0x400000000003a180]
[0x4000000000002c20]
[0x4000000000004f90]
[0x40000000002b8af0]
[0x4000000000000280]
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
you may safely reboot your system

This happens just after "Welcome to Fedora" hits the screen.
Comment 1 David Cantrell 2007-03-07 11:21:10 EST
Won't be able to resolve this today, so just use yesterday's tree until I can
fix it.

The backtrace:

dcantrel@mortise:~/anaconda-debuginfo-11.2.0.31-1/usr/lib/debug/usr/lib/anaconda
-runtime/loader$ eu-addr2line -e loader.debug 
0x4000000000000530
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:1255
0xa0000000000107e0
??:0
0x400000000032c600
/usr/src/debug/anaconda-11.2.0.31/stubs/unicode-lite.c:29
0x400000000003a180
/usr/src/debug/anaconda-11.2.0.31/loader2/net.c:435
0x4000000000002c20
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:1102
0x4000000000004f90
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:1557
0x40000000002b8af0
/usr/src/debug/anaconda-11.2.0.31/stubs/unicode-lite.c:29
0x4000000000000280
??:0

None of those lines were touched in yesterday's build, so I need to do some more
digging.
Comment 2 Adrian Reber 2007-03-08 05:12:15 EST
same on ppc with the ppc64.img :

loader received SIGSEGV!  Backtrace:                                           
[0x1000037c]
[0x100344]
[0x8000]
[0x80808080]
[0x100185fc]
[0x1001ee5c]
[0x10017bf8]
[0x10018334]
[0x100018ec]
[0x1000292c]
install exited abnormally [1/1] 

with "anaconda installer init version 11.2.0.31 starting"
Comment 3 David Cantrell 2007-03-08 11:43:05 EST
Backtrace for ppc64 boot (for my own reference later):

dcantrel@mortise:~/anaconda-debuginfo-11.2.0.31-1/usr/lib/debug/usr/lib/anaconda
-runtime/loader$ eu-addr2line -e loader.debug 
0x1000037c
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:172
0x100344
??:0
0x8000
??:0
0x80808080
??:0
0x100185fc
/usr/src/debug/anaconda-11.2.0.31/loader2/nfsinstall.c:361
0x1001ee5c
/usr/src/debug/anaconda-11.2.0.31/loader2/net.c:398
0x10017bf8
/usr/src/debug/anaconda-11.2.0.31/loader2/hdinstall.c:257
0x10018334
/usr/src/debug/anaconda-11.2.0.31/loader2/hdinstall.c:226
0x100018ec
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:962
0x1000292c
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:1425
Comment 4 David Cantrell 2007-03-08 11:56:59 EST
OK, so the good news is I don't think it's related to just 64-bit platforms.  It
seems that loaderData->ip is NULL under certain circumstances.  Working on
reproducing that locally, but I think the fix will be pretty simple to some
changes I made a couple days ago.
Comment 5 David Cantrell 2007-03-08 12:35:35 EST
Created attachment 149596 [details]
Patch to loader to handle loaderData->ip being NULL

This is what I think is needed to fix the problem.  I am building new
initrd.img files for ia64 and ppc64 and will attach those to this bug report so
you can test.  I don't have those platforms at my disposal easily.
Comment 6 Jarod Wilson 2007-03-08 13:12:23 EST
I've got both ia64 and ppc64 boxes in my cube. If ya have need (notice I didn't
say "want") to get on one, just ask... :) Otherwise, I'm happy to try out the
fix myself.
Comment 7 David Cantrell 2007-03-08 13:54:12 EST
Created attachment 149606 [details]
Updated anaconda SRPM with loader patch.

Here is a patched SRPM for anaconda-11.2.0.31 that you can rebuild locally if
you need to.
Comment 8 David Cantrell 2007-03-08 14:35:18 EST
Created attachment 149613 [details]
New initrd.img for IA64

New network boot initrd.img for IA64.  Please test.
Comment 9 David Cantrell 2007-03-08 14:51:22 EST
Created attachment 149615 [details]
New ramdisk.image.gz for PPC64

New ramdisk.image.gz for PPC64.  Please test.
Comment 10 David Cantrell 2007-03-08 14:52:36 EST
Please test these new ramdisk images with a rawhide-20070308 tree.
Comment 11 Jarod Wilson 2007-03-08 16:07:40 EST
No luck, still bombed on ia64. Slightly different backtrace this time (did http
install, plus I presume code added may have changed line numbers):

loader received SIGSEGV!  Backtrace:                                           
[0x4000000000000530]
[0xa0000000000107e0]
[0x40000000000aabd0]
[0x40000000000aac40]
[0x4000000000031410]
[0x400000000003f0f0]
[0x400000000002fc70]
[0x4000000000030ce0]
[0x4000000000002dd0]
[0x4000000000005450]
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
you may safely reboot your system
Comment 12 David Cantrell 2007-03-08 18:26:53 EST
$ eu-addr2line -e loader.debug < backtrace 
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:1272
??:0
/usr/src/debug/anaconda-11.2.0.31/isys/str.c:87
/usr/src/debug/anaconda-11.2.0.31/isys/str.c:107
/usr/src/debug/anaconda-11.2.0.31/loader2/net.c:1932
/usr/src/debug/anaconda-11.2.0.31/loader2/urls.c:179
/usr/src/debug/anaconda-11.2.0.31/loader2/urlinstall.c:60
/usr/src/debug/anaconda-11.2.0.31/loader2/urlinstall.c:114
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:1150
/usr/src/debug/anaconda-11.2.0.31/loader2/loader.c:1574

Another string being NULL.  Fixing.  Going ahead and building an anaconda for
tonight's build, we'll go with tomorrow's tree and see if things work or are
still broken.
Comment 13 David Cantrell 2007-03-09 14:58:48 EST
OK, I've been testing the fixes today and it looks like I've fixed all of the
things that SIGSEGV that have been reported here. (famous last words).

Closing as rawhide and building a new anaconda.

Note You need to log in before you can comment on or make changes to this bug.