Bug 231292 - 'Inactive Servers WILL BE DELETED' email has pxt links
'Inactive Servers WILL BE DELETED' email has pxt links
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
Corey Welton
:
Depends On:
Blocks: 229277
  Show dependency treegraph
 
Reported: 2007-03-07 10:21 EST by Máirín Duffy
Modified: 2007-05-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn501h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 22:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full email text (3.72 KB, text/plain)
2007-03-07 10:21 EST, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2007-03-07 10:21:26 EST
Description of problem:
The links still seem to work in prod right now (416 in prod) but:

https://rhn.redhat.com/network/systems/system_list/inactive.pxt
https://rhn.redhat.com/help/forgot_password.pxt

Are currently sent out in the 'activate servers will be deleted' email. These
links should be:

https://rhn.redhat.com/rhn/systems/Inactive.do
https://www.redhat.com/wapps/sso/rhn/lostPassword.html

For now, they seem to work althoug the inactive system list is a little funky
(it appears as if it's part of your rhn instead of systems.) While the
forgot_password.pxt page loads, I don't know if it's resetting passwords
correctly, etc.

I'm attaching the full text of the message I received from RHN.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Máirín Duffy 2007-03-07 10:21:27 EST
Created attachment 149457 [details]
full email text
Comment 2 Bret McMillan 2007-03-16 14:27:19 EDT
I'm pretty sure we stopped running the actual deletion script.  One would think
we'd either stop this mailing, or start the deletions and fix this script.

Mike, can you track this down w/ soc?
Comment 3 Bret McMillan 2007-03-16 14:27:49 EDT
I'm pretty sure we stopped running the actual deletion script.  One would think
we'd either stop this mailing, or start the deletions and fix this script.

Mike, can you track this down w/ soc?
Comment 4 Mike Orazi 2007-03-26 14:42:34 EDT
Updated the mail template (501 hosted, rev 113846).  There is still an ongoing
discussion with prod ops, but the fix was easy enough that it is better to just
have it in place.
Comment 5 Bret McMillan 2007-03-27 15:27:08 EDT
Test plan?
Comment 6 James Bowes 2007-04-19 11:08:37 EDT
1.  Stop sendmail,
2.  /usr/bin/fakemail.py --port=25 --log=/var/log/rhn/notify_server.log
3.  set notify_servers to 1 in /etc/rhn/default/rhn_tools.conf
4.  Run notify_server --verbose (from /etc/cron.daily/notify_server),
5.  grep for an email address in /var/spool/clientmqueue
6.  find a line that starts with E-Mail:
6.  look in the file containing that line, and observe that the links are fixed. 
Comment 7 Corey Welton 2007-04-30 16:12:06 EDT
Verified that nothing with 'pxt' appears in the generated emails.
Comment 8 Corey Welton 2007-05-09 17:14:39 EDT
Should be on Stage - not possible for QA to verify, however.
Comment 9 Brandon Perkins 2007-05-16 22:20:54 EDT
Closed for RHN 501 Hosted.

Note You need to log in before you can comment on or make changes to this bug.