This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 23131 - sshd spawning bash in an infinite loop
sshd spawning bash in an infinite loop
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-02 05:57 EST by Gerald Teschl
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 08:28:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-01-02 05:57:30 EST
It looks like under some instances, when a user logs in
via ssh, sshd starts spanning bash processes in an infinite
loop. The whole system will be blocked until the kernel runs
out of memory and kills sshd:
 
kernel: VM: killing process sshd
 
After that everything is fine again.
Comment 1 Bill Nottingham 2001-01-02 12:01:52 EST
What's the users .bash* files look like?
Comment 2 Gerald Teschl 2001-01-02 13:55:11 EST
.bash_profile = RH default
.bashrc
-----------------
# .bashrc

# Source global definitions
if [ -f /etc/bashrc ]; then
        . /etc/bashrc
fi

# User specific aliases and functions

PATH="$PATH:~/bin:."
export PRINTER=dev-null
export EDITOR=joe
umask 007
Comment 3 Nalin Dahyabhai 2001-01-15 21:27:47 EST
Can you be more specific about "some instances"?  Does it happen regularly for
some users? for all users?  Does adding "set -x" to the top of the .bashrc file
shed any light on this?
Comment 4 Gerald Teschl 2001-03-23 08:28:42 EST
Never occured again.

Note You need to log in before you can comment on or make changes to this bug.