This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 231326 - syslog should only log in its own timezone (ignore local client timezone)
syslog should only log in its own timezone (ignore local client timezone)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sysklogd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brian Brock
http://cvs.infodrom.org/sysklogd/sysl...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-07 14:07 EST by Matthew Miller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 05:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-03-07 14:07:19 EST
Description of problem:

Currently, syslog follows the timezone setting of whatever program is doing the
logging. Thus, programs which happen to run in UTC or some other timezone appear
to log odd times (the actual zone used is never recorded in the log file). 

Perhaps worse, I can log with an almost arbitrary timestamp if I so choose:

TZ="UTC+23:56" logger "Look! I'm logging from yesterday!"


Version-Release number of selected component (if applicable):

1.4.1

How reproducible:

Innate.

Steps to Reproduce:
1. set TZ to anything you like
2. log a message
3. look in the appropriate log file
  
Actual results:

Time logged in the timezone you specified, but without saying so.

Expected results:

Time logged in the timezone under which syslogd is running.

Additional info:

There is a patch for this in the unreleased-for-years-and-years syslog 1.4.2. I
think we should backport this into Fedora. See:

http://cvs.infodrom.org/sysklogd/syslogd.c.diff?r1=1.43;r2=1.44;f=h
Comment 1 Nicolas Mailhot 2007-03-07 15:34:43 EST
will this display timestamps in a sane datetime format like ISO 8601 ?
Comment 2 Matthew Miller 2007-03-07 15:40:54 EST
No, it doesn't change the file format at all. It just consistently makes syslog
use the timezone it is running under rather than the timezone of the logging client.

While it'd be nice if syslog would use a better date/format, changing the format
of log files would be a fairly major undertaking and would need to be done with
a lot of care.
Comment 3 Matthew Miller 2007-03-08 14:27:38 EST
Here's an example of the practical implication of this: bug #203671.
Comment 4 Peter Vrabec 2007-03-12 05:02:19 EDT
fixed in sysklogd-1.4.2-2.fc7
Comment 5 Matthew Miller 2007-03-12 08:05:11 EDT
Looks like this was already done by the time I filed it, huh? Thanks for the
psychic bug fix. :)

Note You need to log in before you can comment on or make changes to this bug.