Bug 23134 - Can't install from parallel port CD-ROM drive
Can't install from parallel port CD-ROM drive
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
Florence Beta-3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-02 07:05 EST by Tim Waugh
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 16:09:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2001-01-02 07:05:26 EST
The installer seems to be doing the following:

- extract paride
- insmod paride
- rmmod paride
- extract aten
- insmod aten (fails)
- insmod paride
- insmod aten
- rmmod aten paride
(repeat for bpck, etc)
- extract pcd
- insmod pcd (fails)

It _should_ do the following instead:

- extract paride
- insmod paride
- extract aten
- insmod aten
- extract bpck
- insmod bpck
(repeat for other protocols)
- extract pcd
- insmod pcd

I.e. it should load _all_ of the modules, with paride first and pcd last.
Comment 1 Tim Waugh 2001-01-02 07:26:05 EST
(and actually this is with qa1229.0, not beta1)
Comment 2 Michael Fulbright 2001-01-03 16:21:52 EST
Assigning to a developer.
Comment 3 Tim Waugh 2001-01-04 12:39:55 EST
Found the problem: paride.o is not in drivers.img's modules.cgz. :-/

paride.o needs to be in that, and also a line in modules.dep that says:

paride: parport_pc

With those changes, installing from Backpack CD-ROM succeeds.
Comment 4 Tim Waugh 2001-01-10 08:49:21 EST
This is still broken in beta 2.

There must be something going wrong with dependency resolution for driver disks.  pcd.o is there, but paride.o (which is uses symbols from) just isn't.
Comment 5 Glen Foster 2001-01-11 16:16:45 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 6 Erik Troan 2001-01-16 18:11:23 EST
We weren't looping over the dependency resolution when building disks. This
should be fixed now, and I've sent twaugh a driver disk to try w/ beta 2.

Note You need to log in before you can comment on or make changes to this bug.