Bug 231377 - instnum.py and regnum-service disagree on Product Option Encoding in IN
Summary: instnum.py and regnum-service disagree on Product Option Encoding in IN
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Product_Activation (Show other bugs)
(Show other bugs)
Version: web231
Hardware: All Linux
urgent
high
Target Milestone: ---
Assignee: joseph canton
QA Contact: Web Development
URL: http://any
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-07 22:32 UTC by joseph canton
Modified: 2007-03-15 15:06 UTC (History)
2 users (show)

Fixed In Version: 231
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 15:06:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spreadsheet used by Matt Webbink to determin proper Product Option Code key (64.18 KB, application/vnd.sun.xml.calc)
2007-03-07 22:32 UTC, joseph canton
no flags Details

Description joseph canton 2007-03-07 22:32:34 UTC
Description of problem:
Option Code of IN generated by regnum-service do not match decode via instnum.py
 Error may be in either installer python code or web java code, or in
invalid options spreadsheet. location of error currently undefined.

Steps to Reproduce:
1.hock an installation number for MCT0982
2.decode installation number using instnum.py


  
Actual results:

[jcanton@jcanton-workstation site-packages]$ ./instnum.py f9ec20b7f873da20
Product: RHEL Server
Type: Entitlement
Options: Premium FullProd Virt
Allowed CPU Sockets: Unlimited
Allowed Virtual Instances: Unlimited
Package Repositories: Server VT

key: 16378912 'f9ec20'
checksum: 183 'b7'
options: 784 'Premium FullProd Virt'
socklimit: -1 'Unlimited'
virtlimit: -1 'Unlimited'
type: 1 'Entitlement'
product: 0 'server'

{'Virt': 'VT', 'Base': 'Server'}

f9ec-20b7-f873-da20
[jcanton@jcanton-workstation site-packages]$

Expected results:
Options: Standard FullProd Virt, rather than Premium FullProd Virt



Additional info: ref also bugzilla 219519

Comment 1 joseph canton 2007-03-07 22:32:34 UTC
Created attachment 149512 [details]
spreadsheet used by Matt Webbink to determin proper Product Option Code key

Comment 2 joseph canton 2007-03-08 14:18:13 UTC
see bug 219519 re possible mismatch between spreadsheet and python code. 
Am making this bug public to ensure access for engineering.

Comment 3 Daniel Riek 2007-03-08 14:48:32 UTC
I veified with the poc code and the result is:
>>> RHEL_InstNumDecoder.InstNumDecoder("f9ec20b7f873da20").getValuesExplicit()
('rhel_server', -1, -1, 103L, ['Premium', 'Virt', 'FullProd'], 1L, 1)

So this seems to be an encoder problem.

Comment 4 Mark Sechrest 2007-03-08 16:34:26 UTC
Last I heard, Matt Webbink just received a new spreadsheet of sku/product option
code mappings, and they are different. He needs to reconfigure all of the skus,
and then we can retest.

Moving to Assigned, pending this data update.

Comment 5 Daniel Riek 2007-03-08 18:17:30 UTC
The problem was a miscommunication on my side. I had not CCed Matt on the update
in December.

Matt now has the current information. 

Bug #231377 has the data.

Comment 6 Daniel Riek 2007-03-08 18:17:48 UTC
Sorry that was bug #219519

Comment 7 joseph canton 2007-03-09 13:41:08 UTC
No code changes required. Hence no revision numbers. New spreadsheet data must
be either entered or inserted into the db's. Check w/ Matt re status. Marking
this bug as modified, although  db update may not be yet complete.

Comment 8 Steve Milner 2007-03-09 20:56:02 UTC
Updated to ON_QA buy bugzillaupdater

Comment 9 David Spalding 2007-03-10 21:19:51 UTC
Checkd on QA, checks good.

Comment 10 Mark Sechrest 2007-03-15 15:06:53 UTC
Fixes released


Note You need to log in before you can comment on or make changes to this bug.