Bug 231426 - RAID installation not detected for upgrade
RAID installation not detected for upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-03-07 23:22 EST by Zathros
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 12:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zathros 2007-03-07 23:22:54 EST
Description of problem:
Fedora installation on RAID 1 volume was not detected by the installer. The
configuration used 3 sata hard drives with 1 hot spare. There was also a second
raid 5 partition which was used for LVM. This was also not detected. The next
screen showed the partition layout as having one RAID 1 device of the smaller
size with 4 hot spares. The correct layout should have been one RAID1 device of
the smaller size, one RAID5 device of the larger size, and LVM over the RAID5.

Version-Release number of selected component (if applicable):


How reproducible:
Consistently.

Steps to Reproduce:
1. Install FC6 with 3 drives. Use RAID1 with 1 hot spare for / and RAID5 and LVM
for /home. 
2. Attempt to upgrade using FC7 test 2.

Actual results:
Fedora installation is not detected. Partition layout in next screen is incorrect.

Expected results:
Fedora Core 6 installation should be detected on RAID 1 partition. Upgrade
should complete successfully on this partition.

Additional info:
Comment 1 Matthew Miller 2007-04-10 12:26:26 EDT
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.
Comment 2 Will Woods 2007-05-09 18:02:50 EDT
A couple of questions:

Are all the drives SATA drives? Are they all on the same controller?
Do they get different device names in F7 than they had in FC6?

Is this regular Linux software RAID (mdraid) or some other type of BIOS/hardware
RAID?
Comment 3 Zathros 2007-05-09 19:26:27 EDT
Answers:

Yes. All are SATA drives. All are on the same controller, built into the ASUS
P5LD2-VM motherboard. 

I was using regular software RAID (mdraid). No BIOS/hardware stuff.

I really don't know about the device names any more. It is possible that they
may have changed. I have since reinstalled, so the old layout is gone. It is
possible to reproduce the above configuration, though. 

Also, I have not tested this against F7 test4. Any reason to believe it would be
different?
Comment 4 Will Woods 2007-05-15 17:34:12 EDT
Were there other drives in the system (USB, IDE, etc.) that might have caused
the devices to change numbering?
Comment 5 Zathros 2007-05-15 20:19:07 EDT
No drives were added or removed. Nothing was plugged into USB. I see no obvious
reason for devices to have changed numbering. 

If they did somehow change numbering, should I not have still expected this to
work given that all three drives were still present? 
Comment 6 Jeremy Katz 2007-05-21 13:43:17 EDT
rawhide as of tomorrow should be better here with switching to mdadm across the
board which should be a little bit more resilient to things moving around. 

Can you try with tomorrow's tree and see if it does any better?
Comment 7 Jarod Wilson 2007-05-24 18:28:39 EDT
This works for me today. Was able to upgrade both a 2-drive mdraid system (mix
of raid0 and raid1 arrays) and a 4-drive mdraid system (raid1 and raid6).
Comment 8 Will Woods 2007-05-27 16:08:33 EDT
All our testing indicates that this is fixed in rawhide and F7rc2. If possible,
could you retest and confirm the fix?

Note You need to log in before you can comment on or make changes to this bug.