Bug 231489 - freetype 32-bit RPM build incorrect on x86_64
freetype 32-bit RPM build incorrect on x86_64
Status: CLOSED DUPLICATE of bug 232429
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Panu Matilainen
Depends On:
  Show dependency treegraph
Reported: 2007-03-08 13:07 EST by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-08 09:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2007-03-08 13:07:54 EST
Description of problem:
I wanted to recompile freetype2 SRPM (to change some build-time option :-),
but I was not able to build a 32-bit version on my x86_64 system.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. rpm -i freetype-2.2.1-16.fc6.src.rpm
2. rpmbuild -ba --target i686 freetype.spec
3. rpm -qpl ../RPMS/i686/freetype-2.2.1-16.i686.rpm | grep /lib
Actual results:
i.e., the 32-bit libraries (provided they have been built correctly as 32-bit
ones :-) end up in /usr/lib64 instead of /usr/lib

Expected results:

Additional info:
Comment 1 Matthias Clasen 2007-04-24 00:58:30 EDT
Not a freetype bug. This is about setting up a working environment for multilib 
Comment 2 Jan "Yenya" Kasprzak 2007-04-24 06:56:14 EDT
In this case - maybe RPM can be hacked to check all the packaged files with
file(1) to automatically detect this problem and refuse to build the RPM
containing files for wrong arch (in the same way it checks for unpackaged
files or for auto dependencies).
Comment 3 Jeff Johnson 2007-04-24 16:57:57 EDT
The means to hack rpm to automate the check already exist, other hacks are in the redhat-rpm-config 

NOTABUG for rpm
Comment 4 Red Hat Bugzilla 2007-08-21 01:32:25 EDT
User pnasrat@redhat.com's account has been closed
Comment 5 Panu Matilainen 2007-08-22 02:34:37 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 6 Panu Matilainen 2007-10-08 09:01:38 EDT

*** This bug has been marked as a duplicate of 232429 ***

Note You need to log in before you can comment on or make changes to this bug.