Bug 23153 - alt- changed to meta-
Summary: alt- changed to meta-
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-02 16:31 UTC by Tim Waugh
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 18:01:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2001-01-02 16:31:50 UTC
Where I used to use alt-tab to switch between windows in GNOME, now it
seems to be bound to meta-tab (different modifier key).  Is this an accident?

Comment 1 Havoc Pennington 2001-01-02 21:49:53 UTC
It's always been Meta in the config file, apparently either your keyboard used
to bind Meta to Alt, or Sawfish used to pretend Alt was Meta. How is your
keyboard set up?

Comment 2 Tim Waugh 2001-01-03 18:01:45 UTC
It's a Happy Hacking keyboard, with DIP switches 1 and 2 on and the others off,
which apparently makes my '<>' key behave like a Windows key.

Perhaps I'm mistaken.  I've just noticed that my 'Alt' and '<>' keys are in a
different order to my Windows key and Alt key on all the other keyboards I've
used..

Comment 3 Tim Waugh 2001-01-03 18:06:40 UTC
It's certainly true though that on the HHK 'Alt+Tab' does NOT cycle through
windows where '<>+Tab' DOES, and the configuration is 'M-TAB' for cycle and
'meta' for modifier key, but on another 7.1-beta1 machine 'Alt+Tab' DOES cycle
and 'W+Tab' does NOT, with the same configuration.

I guess it's just a weird HHK thing.  NOTABUG I guess.

Comment 4 Havoc Pennington 2001-01-03 18:30:01 UTC
If you want to know what keysyms your keys are actually sending, you can use
"xev" to look at key events

Comment 5 Tim Waugh 2001-01-11 16:43:41 UTC
On the HHK, Alt produces Alt_L and <> produces Meta_L.

Comment 6 Mike A. Harris 2001-04-12 12:15:44 UTC
This bug was caused by a change in keyboard mappings in XFree86 a while
back which bound Meta to the Win keys.  I have changed it back to ALT
for the 105 keyboards.  XFree86 4.0.3 from seawolf should do the job.


Note You need to log in before you can comment on or make changes to this bug.