Bug 231531 - librsvg2 in ImageMagick comes at a big dependency chain cost [NEEDINFO]
librsvg2 in ImageMagick comes at a big dependency chain cost
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: librsvg2 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
: 477543 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-08 16:07 EST by Greg Swallow
Modified: 2014-07-16 07:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (greg)


Attachments (Terms of Use)
spec file changes to not require gnome-vfs (1.58 KB, patch)
2007-03-08 18:40 EST, Greg Swallow
no flags Details | Diff

  None (edit)
Description Greg Swallow 2007-03-08 16:07:35 EST
Ditto for RHEL5 beta2.  Seems rather unnecessary for a server without X.  I 
tried to install ImageMagick-perl (and ImageMagick) and it wanted to install 
50 packages in total.  Trying to install just librsvg2 pulls in 29 packages.


+++ This bug was initially created as a clone of Bug #212478 +++

I was about to upgrade a trimmed-down, headless FC5 PVR box to FC6, and 
noticed that the upgrade wanted to pull in lots of GNOME related things.  I 
need ImageMagick on that box, and it turns out that the almost-certain culprit 
is the librsvg2 support/dependency in it which has been added in FC6.

ImageMagick seems to have some internal practically dependencyless SVG 
support, but when librsvg2 support is additionally built in, it seems to 
result in these packages recursively being pulled in in my setup which I have 
no need for and which were not required in FC5:

GConf2
ORBit2
audiofile
avahi
avahi-glib
dbus-python
esound
gamin
gnome-keyring
gnome-mime-data
gnome-mount
gnome-vfs2
libIDL
libXres
libart_lgpl
libbonobo
libcroco
libdaemon
libglade2
libgnome
libgnomecanvas
libgnomeui
libgsf
libnotify
librsvg2
libutempter
libwnck
libxslt
notification-daemon
startup-notification

There might be some false positives in that list, but most of them seem to be 
directly caused by librsvg2.  I don't know what building ImageMagick with it 
is needed for, but the amount of inflicted dependencies (~30 packages) sure 
feels excessive to me...
Comment 1 Greg Swallow 2007-03-08 16:27:32 EST
Actually, the problem could be blamed instead on librsvg2, which requires 
gnome-vfs2 - If I install gnome-vfs2, that pulls in 26 packages.  I am going 
to change the component of this bug report to librsvg2.
Comment 2 Greg Swallow 2007-03-08 18:40:42 EST
Created attachment 149658 [details]
spec file changes to not require gnome-vfs

Here's a patch of changes to the specfile that removes the gnome-vfs
requirement.  I don't know if it breaks anything else that requires librsvg2 -
I'll leave that up to you to check that.
Comment 3 Greg Swallow 2007-03-08 18:42:28 EST
The patch was for the rawhide version - Maybe the bug should be cloned to 
rawhide?  I will leave that up to you, as I am not sure if the change is ok or 
not.  
Comment 5 RHEL Product and Program Management 2014-03-07 07:50:24 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 6 RHEL Product and Program Management 2014-06-02 09:20:00 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 7 Ondrej Vasik 2014-07-16 07:35:38 EDT
*** Bug 477543 has been marked as a duplicate of this bug. ***
Comment 8 Jarkko 2014-07-16 07:43:18 EDT
Fixed in EL6.

Note You need to log in before you can comment on or make changes to this bug.