Bug 231581 - Orinoco PCMCIA wireless card won't associate with access point
Orinoco PCMCIA wireless card won't associate with access point
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-09 00:38 EST by David Baron
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-09 12:31:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages from dmesg (relevant tail of its output), with annotations (8.06 KB, text/plain; charset=UTF-8)
2007-03-09 00:38 EST, David Baron
no flags Details

  None (edit)
Description David Baron 2007-03-09 00:38:04 EST
Description of problem:  My orinoco PCMCIA wireless card won't associate with
the access point.

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2975.fc7
initscripts-8.51-1
NetworkManager-0.6.5-0.3.cvs20061025.fc7
pcmciautils-014-5

How reproducible: always

Steps to Reproduce:
1. /sbin/iwconfig eth1 essid "my-essid"
2. /sbin/iwconfig eth1
    Actual results: shows correct essid and channel, but shows
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
    Expected results: shows link quality / signal / noise
3. /sbin/ifup eth1
    Actual results:
Determining IP information for eth1... failed; no link present.  Check cable?
4. /sbin/service NetworkManager start
    Actual results:
    NetworkManager won't connect to network, even though the card can scan

Additional info:

Note that /sbin/iwlist eth1 scan only shows good scanning information if I've
run NetworkManager since the last reboot.

The card is, according to lspcmcia -v:
Socket 0 Device 0:      [orinoco_cs]            (bus ID: 0.0)
        Configuration:  state: on
        Product Name:   Lucent Technologies WaveLAN/IEEE Version 01.01 
        Identification: manf_id: 0x0156 card_id: 0x0002
                        function: 6 (network)
                        prod_id(1): "Lucent Technologies" (0x23eb9949)
                        prod_id(2): "WaveLAN/IEEE" (0xc562e72a)
                        prod_id(3): "Version 01.01" (0xd27deb1a)
                        prod_id(4): --- (---)
and on the outside it says it's a Lucent Technologies orinoco 11 Mbit/s SILVER.

I installed F7 test 1 on my old laptop to test it (it previously had Fedora Core
3, and I hadn't used it since Fedora Core 3 was the current release).  So I can
say that this is a regression since FC3, but I suspect that's not very useful.

dmesg shows some interesting messages, but I couldn't get the most interesting
looking one (about a possible circular locking dependency) to happen again, so
I'm not exactly sure what caused it.  However, I'll attach the messages.
Comment 1 David Baron 2007-03-09 00:38:04 EST
Created attachment 149669 [details]
messages from dmesg (relevant tail of its output), with annotations
Comment 2 John W. Linville 2007-03-09 11:09:50 EST
Have you tried moving closer to the AP?  Do you know for certain that the card 
is still good?
Comment 3 David Baron 2007-03-09 12:31:08 EST
Ok, seems the card isn't good anymore.  (I thought I'd tried it in FC3 before
upgrading, but I guess I hadn't.)

Note You need to log in before you can comment on or make changes to this bug.