Bug 231599 - MH-E doesn't complete threading a folder
MH-E doesn't complete threading a folder
Product: Fedora
Classification: Fedora
Component: xemacs-packages-extra (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-03-09 07:27 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-01 11:52:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2007-03-09 07:27:09 EST
Description of problem:
In an MH-E folder buffer, pressing "T t" (to thread it) just gives 'End of file
or stream: "internal input stream"', the folder isn't threaded

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. M-x mh-rmail
2. Tt
Actual results:
End of file or stream: "internal input stream"

Expected results:
Threaded folder

Additional info
xemacs-21.5.27-8.fc7, it used to work with the version before this one.
Comment 1 Ville Skyttä 2007-03-11 11:44:38 EDT
(In reply to comment #0)
> xemacs-21.5.27-8.fc7, it used to work with the version before this one.

Hm, previous version of xemacs or xemacs-packages-extra?  Which are the exact
versions of xemacs and xemacs-packages-extra it worked with?
Comment 2 Horst H. von Brand 2007-03-11 11:59:34 EDT
xemacs, xemacs-packages-extra hasn't changed in ages (it is still .fc6).
xemacs-packages-{base,extra} are from Sep 10, 2006, installed the next day.

I dunno which version of xemacs was before, the rotation of yum.log erased the
record of that one's installation.
Comment 3 Ville Skyttä 2007-03-11 13:05:39 EDT
The only changes between xemacs 21.5.27-7.fc7 and 8.fc7 were these:


Both look innocent enough to me, but perhaps you could test if reverting the
site-start.el change has any effect.  What's your $LANG environment variable set to?
Comment 4 Horst H. von Brand 2007-03-15 11:31:03 EDT

In any case, this went away (by mistake I tried reading email in xemacs, and it
worked this time, after reliably *not* working starting last week). Sorry, I
can't point at any of the many updates to rawhide which fixed this.

I guess you can close it now... sorry for the time wasted.

Comment 5 Horst H. von Brand 2007-03-17 20:22:47 EDT
Sorry, false alarm. When threading a huge folder (a few thousand messages,
message numbers up in the 80 thousands) it hung again. The workaround was to
thread the folder in plain emacs, delete a few hundred messages (junk easily
sorted by Subject:) and get at it again in xemacs.
Comment 6 Horst H. von Brand 2007-07-17 09:27:07 EDT
Futzing around with GNU emacs, it seems that when deleting a large number of
messages (or large messages) it runs out of "undo" space (that is the message
GNU emacs gives, instead of just hanging).

Why does it save the deleted messages in undo? MH saves them as ",<msg>" in the
folder, so they aren't lost. I suspect this is what makes many MH-E operations slow.
Comment 7 Horst H. von Brand 2007-10-01 09:29:07 EDT
After not using xemacs for quite some time for email, I tried again. I now seems
to work (xemacs-21.5.28-5.fc8, xemacs-packages-extra-20070427-1.fc8,
Comment 8 Ville Skyttä 2007-10-01 11:52:03 EDT
Thanks for the feedback, assuming fixed.

Note You need to log in before you can comment on or make changes to this bug.