Bug 231639 - [Symantec 5.1 bug] kernel thread current->mm dereference in grab_swap_token causes oops
Summary: [Symantec 5.1 bug] kernel thread current->mm dereference in grab_swap_token c...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jerome Marchand
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: Regression
Depends On: IT_71391
Blocks: 243319 217203
TreeView+ depends on / blocked
 
Reported: 2007-03-09 17:51 UTC by Andrius Benokraitis
Modified: 2015-07-14 04:25 UTC (History)
8 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:43:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Comment 2 Andrius Benokraitis 2007-03-09 18:02:48 UTC
Neena, please post an updated patch here, or provide a link to the patch
required for inclusion in RHEL 5.1.

Comment 3 RHEL Product and Program Management 2007-03-09 18:04:24 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 5 Neena Bhatnagar 2007-03-09 18:13:26 UTC
The patch in is linux-2.6.9-vm-swaptoken-null-mm.patch
>>>>
>>>>
>>>> --- linux-2.6.9/mm/thrash.c~    2005-04-27 23:35:17.000000000 -0400
>>>> +++ linux-2.6.9/mm/thrash.c     2005-04-27 23:35:49.000000000 -0400
>>>> @@ -50,6 +50,10 @@ void grab_swap_token(void)
>>>>         struct mm_struct *mm;
>>>>         int reason;
>>>>
>>>> +       /* Some kernel threads without mm can fault on behalf of
> others.
>>>> */
>>>> +       if (unlikely(!current->mm))
>>>> +               return;
>>>> +
>>>>         /* We have the token. Let others know we still need it. */
>>>>         if (has_swap_token(current->mm)) {

----8<----
neena-

Comment 9 Andrius Benokraitis 2007-03-09 18:28:51 UTC
Thanks Neena, I've included RH kernel management to assess this issue.

Comment 12 Andrius Benokraitis 2007-03-22 03:43:42 UTC
Ram, can you verify the code in Comment #5 has been tested by Symantec?

Comment 13 Peter Kettle 2007-03-22 12:03:04 UTC
Yes, we have tried this in a patched kernel and it definitely fixes the 
problem.

Regards, Peter Kettle, peter_kettle@symantec.com

Comment 14 Jerome Marchand 2007-03-26 17:25:59 UTC
Patch submitted to rhkernel-list:
http://post-office.corp.redhat.com/archives/rhkernel-list/2007-March/msg00716.html

Comment 15 RHEL Product and Program Management 2007-03-28 12:21:55 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 16 Don Zickus 2007-05-09 18:21:00 UTC
in 2.6.18-18.el5

Comment 17 Rita Sequeira 2007-05-10 09:45:23 UTC
2.6.18-18.el5 - Where can I pick this kernel

Rita

Comment 18 Andrius Benokraitis 2007-05-10 14:23:38 UTC
Rita:

http://people.redhat.com/dzickus/el5

Comment 19 Andrius Benokraitis 2007-07-06 05:21:27 UTC
Rita, any word on the testing? I'm assuming Peter's comments above still hold?

Also, our QE group is looking into how we can reproduce this, is the setup
pretty involved?

Comment 22 Mike Gahagan 2007-08-28 19:14:28 UTC
Confirmed by running testcase in rhts manually... systems stays up running the
-43 kernel, panics with ga kernel.


Comment 23 Peter Kettle 2007-08-30 09:51:19 UTC
We've now completed our own testing and we are happy for you to close this 
case.  Thanks for all of your help.

Peter Kettle
peter_kettle@symantec.com

Comment 25 errata-xmlrpc 2007-11-07 19:43:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.