Bug 231659 - yum groupinstall KDE... breaks setroobleshoot-server - too many open files
yum groupinstall KDE... breaks setroobleshoot-server - too many open files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-09 15:57 EST by Doncho N. Gunchev
Modified: 2014-01-21 17:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-25 17:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum error while 'yum -y groupinstall "KDE (K Desktop Environment"' (13.48 KB, image/png)
2007-03-09 15:57 EST, Doncho N. Gunchev
no flags Details
setroubleshoot's error? (12.66 KB, image/png)
2007-03-09 16:36 EST, Doncho N. Gunchev
no flags Details
successfull rpm -ihv... (11.68 KB, image/png)
2007-03-09 16:38 EST, Doncho N. Gunchev
no flags Details

  None (edit)
Description Doncho N. Gunchev 2007-03-09 15:57:48 EST
Description of problem:
I installed F6.91 on qemu (no GNOME, no X, no KDE, almost nothing) and updated 
it with yum. After that yum groupinstall "KDE (K Desktop Environment)" broke 
with "too many

Version-Release number of selected component (if applicable):
yum-3.1.4-1.fc7

How reproducible:
Always (tried three times).

Steps to Reproduce:
1. Install F6.91
2. yum -y update
3. yum -y groupinstall "KDE (K Desktop Environment"

Actual results:
yum breaks with:
error: cannot open Packages index using db3 - Too many open files (24)...
etc...
etc...

Additional info:
Look at the screenshot, qemu-0.9.0-2 (FC6), 1GB ram on the machine, 512MB for 
the virtual one + 8G virtual disk.
Comment 1 Doncho N. Gunchev 2007-03-09 15:57:49 EST
Created attachment 149730 [details]
yum error while 'yum -y groupinstall "KDE (K Desktop Environment"'
Comment 2 Doncho N. Gunchev 2007-03-09 16:34:28 EST
Looks like I was wrong about yum, it should be 
setroubleshoot-server-1.9.3-1.fc7. After the previous error I killed yum, 
rebuilt the rpm database (rpm --rebuilddb) and did 
a 'rpm -ihv /var/cache/yum/development/packages/*.rpm' - the same error. 
After 'service setroubleshoot stop; rpm --rebuilddb; setenforce 0' everything 
was fine (and just a bit faster).

Reassigning to setroubleshoot (I see no setroubleshoot-server), don't know 
about the Severity. Will attach screenshots.

Comment 3 Doncho N. Gunchev 2007-03-09 16:36:08 EST
Created attachment 149744 [details]
setroubleshoot's error?
Comment 4 Doncho N. Gunchev 2007-03-09 16:38:36 EST
Created attachment 149745 [details]
successfull rpm -ihv...

after stopping setroubleshoot and setenforce 0 (just for sure) rpm -ihv
--replacepkgs ... succeeded.

Note You need to log in before you can comment on or make changes to this bug.