Bug 231726 - (CVE-2006-7162) CVE-2006-7162: putty <= 0.59 file permissions issues
CVE-2006-7162: putty <= 0.59 file permissions issues
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: putty (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-10 16:28 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.59-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-10 19:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-03-10 16:28:58 EST
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2006-7162

"PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing
private keys generated by puttygen and (2) session logs created by putty, which
allows local users to gain sensitive information by reading these files."

FE5+ seemingly affected.
Comment 1 Jima 2007-03-10 19:49:34 EST
As I stated via email, the NVD bug report is actually incorrect (I'd tell them
if I could find a good contact address); the bug only applies to putty < 0.59. 
I've updated putty in FE5 and FE6 to 0.59-1, which takes care of the issue.

Thanks for the heads-up!

Note You need to log in before you can comment on or make changes to this bug.