Bug 231751 - parted-1.8.2-1.fc6 breaks anaconda
Summary: parted-1.8.2-1.fc6 breaks anaconda
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: parted   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-11 04:40 UTC by David Eisenstein
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 14:58:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Eisenstein 2007-03-11 04:40:57 UTC
Description of problem:
parted-1.8.1 and before provided /usr/lib/libparted-1.8.so.0
parted-1.8.2 now provides        /usr/lib/libparted-1.8.so.2

Any application, including anaconda will no longer work, because the
.so it was linked with, libparted-1.8.so.0, is now gone.


Version-Release number of selected component (if applicable):
parted-1.8.2-1.fc6

How reproducible:
Run any application (other than parted itself) which links into the
libparted.so.

Actual results:
Missing shared library.

Expected results:
Anaconda (and any other apps) should work as before

Comment 1 David Cantrell 2007-03-12 14:56:30 UTC
It's actually pyparted that links with libparted, but a new one should be
available in the updates collection for FC-6.  I build those together whenever I
do updates.  Checking.

Comment 2 David Cantrell 2007-03-12 14:58:53 UTC
Just checked and the update I made for pyparted is in the FC-6 updates
collection.  You need parted-1.8.2-1.fc6 and pyparted-1.8.5-1.fc6 if you want
parted-1.8.2 on your FC-6 system.

Comment 3 Jesse Keating 2007-03-15 14:44:09 UTC
A rebuilt mkinitrd was pushed out to resolve this issue, and resolve it for the
future too.  mkinitrd now shows the specific library requires on parted.


Note You need to log in before you can comment on or make changes to this bug.