Bug 231771 - unhandled exception in pirut, rpmdb open failed
unhandled exception in pirut, rpmdb open failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 218952 231915 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-11 10:29 EDT by ravrat
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 17:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file generated (1.04 KB, application/octet-stream)
2007-03-11 10:29 EDT, ravrat
no flags Details

  None (edit)
Description ravrat 2007-03-11 10:29:04 EDT
Description of problem:
When i run software updater once, then run pirut, it creates an exception. 

Version-Release number of selected component (if applicable):


How reproducible:
run software updater, then let it update, then run add/remove programs. Running
software updater also produces an exception

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 ravrat 2007-03-11 10:29:04 EDT
Created attachment 149792 [details]
log file generated
Comment 2 ravrat 2007-03-11 12:38:45 EDT
i ran yum update from the shell line, and i get the following error
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error, run
database recovery
error: cannot open Packages index using db3 -  (-30977)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
    self.doConfigSetup(fn=opts.conffile, root=root)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in
doConfigSetup
    self.conf = config.readMainConfig(fn, root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 589, in readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 689, in _getsysver
   idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed
Comment 3 Jeremy Katz 2007-03-19 17:58:41 EDT
This is fixed with later kernels.
Comment 4 Jeremy Katz 2007-03-19 18:00:50 EDT
*** Bug 231915 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2007-03-19 18:05:18 EDT
*** Bug 218952 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.