Bug 231787 - ATI rX00 regression between mesa-6.5.1-9 and 6.5.2-5
ATI rX00 regression between mesa-6.5.1-9 and 6.5.2-5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-03-11 17:34 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 6.5.2-13.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 19:37:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-03-11 17:34:35 EDT
Description of problem:
x86_64 machine, ati Radeon 9800 XT, opensource dri drivers. Fully up2date rawhide

With mesa-6.5.1-9 scorchwentbonkers * runs fine, with 6.5.2-5 it shows its
initial blue screen and then nothing happens (no cpu usage either).

* under review:
http://people.atrpms.net/~hdegoede/scorchwentbonkers-1.1-1.fc7.src.rpm
 needs (also under review):
http://people.atrpms.net/~hdegoede/jpgalleg-2.5-1.fc7.src.rpm
Comment 1 Matěj Cepl 2007-03-12 19:24:00 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

Could we get also some logs (or at least stdout/stderr output) from the failing
applications, please?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Hans de Goede 2007-03-13 07:46:31 EDT
As said I encountered this with scorchwentbonkers. I tried to reproduce a bug
reported against scorchwentbonkers on my laptop, and the same happens there.
Again reverting to 6.5.1-9 fixes it. This laptop has a ATI Radeon Mobility M6 /
r100 chip and is i386 not x86_64. So I don't think that attaching any specific
server output will help.

It looks like this is a bug common to all ATI cards and maybe common to the new
mesa independend of the card. Currently I only have access to ati equiped
systems, I'll try this on an i8xx system tomorrow. Let me know if you still want
server outputs despite the fact that this happens on 2 very different systems,
with as only common factors:
1) An ATI chip (r100 versus r300)
2) Problem happens with mesa 6.5.2-x, not with 6.5.1-x



Comment 3 Hans de Goede 2007-03-14 09:25:22 EDT
Okay, I just tried this with mesa-6.5.2-7 on a i8xx equipped computer and it
works there. So this something with the ati driver, but not limited to one type
of ati board.
Comment 4 Hans de Goede 2007-03-18 16:37:17 EDT
I just found another game with the same symptons, blobAndConquor, a i586 rpm is
available from the homepage:
http://www.parallelrealities.co.uk/blobAndConquer.php
Comment 5 Hans de Goede 2007-03-30 18:05:52 EDT
And I just encountered another regression ATI support, atleast r300 is really
broked with 6.5.2, we really _MUST_ fix this before Fedora 7.

The new regression can be seen when running with a depth 24 desktop and then
running the game methane (yum install methane), it show a squashed screen, about
3/4 of normal. It looks like from the texture which is loaded which is in ABGR
format, of each line only 3/4 th gets used and then the next line continues
after it etc.

Since I'm the maintainer of methane I've been debugging this a bit having xorg
run in depth 16, or choosing a different texture format then ABGR (type UNSIGNED
BYTE) fixes this. And so does downgrading to 6.5.1 .

Can we please have some love and attention for this bug, I'm more then willing
to help, do some test compiles with any potential helpfull patches applied, etc.
Comment 6 Hans de Goede 2007-03-31 03:25:22 EDT
Okay,

I've been looking into this myself, since I _really_ want to see this fixed
before Fedora 7 final.

I think the "hanging" (just not showing anything actually) are these upstream
bugs + (already in upstream git) patches:

r300 bug:
http://bugs.freedesktop.org/show_bug.cgi?id=9876
r100 + r200 bug:
https://bugs.freedesktop.org/show_bug.cgi?id=10192
r300 patch:
http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff_plain;h=6f9b1afc862851532e4820705c412388b497ad58;hp=1c70cde8881f794782780cbd695da0882f78c769
r100 + r200 patch:
https://bugs.freedesktop.org/attachment.cgi?id=9084&action=view

I'm testbuilding this now on 3 machines (x86_64 r300 / radeon 9800 pro, i386
r200 / radeon 9250, i386 r100 / radeon M6) I will report back when the builds
are completed.

Comment 7 Hans de Goede 2007-03-31 05:36:19 EDT
I've tested this and applying the patches fixes the scorchwentbonkers and
blobAndConquer hang on all 3 my radeon equiped machines.

I'm also homing in on the methane problem, its caused by this patch:
http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff_plain;h=62d4dfbfe3f7c452f3c182bfdb9270a2f20e3f2d;hp=46c3bd29be4970a8b0c1c358aae0f1d7c05bc9f4
Comment 8 Hans de Goede 2007-03-31 16:32:11 EDT
Okay, I've managed to fully home in on the methane problem, its being caused by
ClanLib being stupid. So've written a fix for ClanLib, ClanLib's stupidness, did
however expose what I believe is a real bug, which I've filed upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=10491

I however do not concider the methane / ClanLib issue a regression anymore
though (see upstream bug for details), so that is no longer relevant for this bug.

---

Summarizing, there is a regression in 6.5.2 for r100 / r200 and r300 cards,
causing certain applications (scorchwentbonkers, blobAndConquer, second life
client are examples) to not render anything. This has been acknowledged and
fixed by upstream, please apply the following 2 patches from upstream to fix
this regression:

r300 patch:
http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff_plain;h=6f9b1afc862851532e4820705c412388b497ad58;hp=1c70cde8881f794782780cbd695da0882f78c769
r100 + r200 patch:
https://bugs.freedesktop.org/attachment.cgi?id=9084&action=view

A rebuild of the srpm with these patches has been successfully tested on 3
machines (x86_64 r300 / radeon 9800 pro, i386 r200 / radeon 9250, i386 r100 /
radeon M6).
Comment 9 Hans de Goede 2007-04-02 14:13:38 EDT
(In reply to comment #8)
> Okay, I've managed to fully home in on the methane problem, its being caused by
> ClanLib being stupid. So've written a fix for ClanLib, ClanLib's stupidness, did
> however expose what I believe is a real bug, which I've filed upstream:
> https://bugs.freedesktop.org/show_bug.cgi?id=10491
> 

Upstream has pointed out to me that the bug causing the methane problem is
already fixed in git, you may want to apply this fix too:
http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff_plain;h=9c09259b8bef8f120cc6f4bb1a44f0eae37d71b3;hp=78a6e054393533a9cb2fe9f5a087d10b0f15bd9c

p.s.

Can this bug please get some attention?? I know you are very busy with the
nouveau stuff, and thats very cool stuff, but please don't leave us ati owners
in the cold. Esp the no image shown regression really should be fixed before
Fedora 7, I've already given the URL's for the patches fixing this twice, and
these patches are in upstream git, so one would assume they are good.

Comment 10 Adam Jackson 2007-04-10 16:23:41 EDT
Fixed in 6.5.2-10, thanks!
Comment 11 Hans de Goede 2007-04-11 07:22:13 EDT
Hmm,

I've just reviewed your changes to be sure everything was ok and I noticed that
the r300 changes were different from those for the r200 and radeon dri drivers
(my fault). It turns out that this problem was originally diagnosed on the r300
and that the fix was done in 2 steps, the patch I pointed you to was only step
1. The r200/radeon then had the both steps "backported" from r300 in one go. In
essence 6.5.2-10 is missing this additional iteration of the fix:
http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commitdiff_plain;h=4d9901a1cab8e0d55b1b2309cf3ffec235e53149;hp=d85667950f6797f63fa0863e6882390c2adaaf2b

Notice that the version you have now is the version I tested and have been
using, but according to the changelog that version of the fix can cause some
troubles, so I think its advisable to update the fix with the second revision
patch linked to above.

Sorry about this.
Comment 12 Adam Jackson 2007-07-09 15:02:30 EDT
np.  Included in 6.5.2-13, which will go out as an F7 update shortly.
Comment 13 Fedora Update System 2007-07-11 11:17:41 EDT
mesa-6.5.2-13.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2007-07-12 19:36:55 EDT
mesa-6.5.2-13.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.