Bug 231800 - erasing dvd-rw with data on it fails due to the disc being mounted
Summary: erasing dvd-rw with data on it fails due to the disc being mounted
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Target F8Target
TreeView+ depends on / blocked
 
Reported: 2007-03-12 03:22 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-21 05:51:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Nielsen 2007-03-12 03:22:47 UTC
Description of problem:
When burning a dvd image of say Fedora 7 test 2 on an existing dvdrw you face a
problem where nautilus-cd-burner doesn't umount the disc before attempting to
erase it - despite getting feedback from the user that he does desire to use
that disc. This causes the entire burn process to fail pending an manual
unmount, though unmounting via nautilus will eject the disc so when you reinsert
it.. the same thing happens again. The only way to get around this is to open a
terminal and umount it manually.

Version-Release number of selected component (if applicable):
nautilus-cd-burner-2.17.8-1.fc7
hal-0.5.9-0.git20070304.fc7
gnome-mount-0.5-3.fc7
nautilus-2.17.92-3.fc7
udev-106-1.fc7
ConsoleKit-0.1.3-0.git20070301.1.fc7
gnome-volume-manager-2.17.0-4.fc7

How reproducible:
100%

Steps to Reproduce:
1. insert dvdrw
2. click .iso file and select "Write to disc"
3. When asked click the erase disc option
  
Actual results:
Failure to erase then burn disc

Expected results:
n-c-b should silently unmount the disc when the user specifically tells it to
erase the disc, then proceed.

Additional info:

Comment 1 Will Woods 2007-05-09 04:36:16 UTC
There have been a lot of updates on this stuff since Test2 - is this still
happening?

Comment 2 David Nielsen 2007-05-09 21:20:29 UTC
I still have to manually umount cd/dvdrw medias before n-c-b will erase them.

Comment 3 sangu 2007-05-19 07:07:36 UTC
nautilus-cd-burner can't blank cdrw in rawhide  20070518.

$cat ~/.xsession-errors
[...]
** (nautilus-cd-burner:6104): WARNING **: Couldn't unmount volume in drive:
/dev/scd0
[...]

$umount /dev/scd0 or $gnome-mount -u -d /dev/scd0 works well.

$ uname -a
Linux localhost.localdomain 2.6.21-1.3163.fc7 #1 SMP Tue May 15 17:23:21 EDT
2007 i686 athlon i386 GNU/Linux

nautilus-cd-burner-2.18.0-2.fc7
nautilus-2.18.1-2.fc7
gnome-vfs2-2.18.1-4.fc7
hal-0.5.9-6.fc7
hal-info-20070516-2.fc7


Comment 4 vfiend 2007-06-09 09:38:09 UTC
I also have this problem with F7 final

Comment 5 vfiend 2007-06-09 09:56:35 UTC
n-c-b should be calling gnome-mount to unmount the drive first or something..

Comment 6 Mykola Lyakhovych 2007-06-16 09:09:51 UTC
I have problem writing disks with gnomebaker. Is it the same problem?
** (gnomebaker:3279): WARNING **: devices_is_disk_inserted - ioctl failed

** (gnomebaker:3279): WARNING **: devices_eject_disk - Error opening device
(\xdf\xd4\u0008/sr0

** (gnomebaker:3279): WARNING **: devices_eject_disk - Error opening device
(\xe7\xc2\u0008/sr0

In /etc/mtab there is an entry with cyrrillic letters (I use Ukrainian):
/dev/scd0 /media/Мой\040диск iso9660 rw,nosuid,nodev,uhelper=hal,uid=500 0 0

I use Fedora 7 with last updates.
Nautilus-cd-burner burns OK.

Comment 7 Mykola Lyakhovych 2007-06-16 09:18:30 UTC
Sorry, I meen n-c-b burnes OK if unmounted manually.

Comment 8 vfiend 2007-06-29 01:57:45 UTC
This seems to be working in F7 updated to GNOME 2.18.2 now

Comment 9 David Nielsen 2007-06-29 09:16:51 UTC
Still occures on Development

Comment 10 David Nielsen 2007-10-21 05:51:18 UTC
Okay, the situation has improved vastly, I'm no longer seeing this.


Note You need to log in before you can comment on or make changes to this bug.