Bug 231921 - Solaris: bindir in mozldap6.pc is not correct
Solaris: bindir in mozldap6.pc is not correct
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Unknown (Show other bugs)
1.0.4
All Other
medium Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-03-12 19:40 EDT by Noriko Hosoi
Modified: 2015-12-07 12:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:12:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
svn diff mozldap6.spec (2.27 KB, patch)
2007-03-12 19:44 EDT, Noriko Hosoi
no flags Details | Diff
cvs diff (build_*mozldap*, mozldap6.spec) (4.15 KB, patch)
2007-03-13 13:22 EDT, Noriko Hosoi
no flags Details | Diff
svn commit message (593 bytes, text/plain)
2007-03-13 13:27 EDT, Noriko Hosoi
no flags Details

  None (edit)
Description Noriko Hosoi 2007-03-12 19:40:03 EDT
Description of problem:
This is the current 
$ less /usr/lib/sparcv9/pkgconfig/mozldap6.pc
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib/sparcv9
includedir=/usr/include/mozldap6
bindir=/usr/bin/sparcv9
major=%major%
[...]

The bindir is picked up when DS is configured and DS scripts are set with the
path for the mozldap6 tools as follows (this is an example picked up from
db2index.pl)
$ENV{'PATH'} = "$prefix/usr/bin/sparcv9:$prefix/usr/bin:/usr/bin/sparcv9:/usr/bin";

On Solaris, there is no LDAP tools in /usr/bin/sparcv9, but Sun system LDAP
tools are located in /usr/bin.  So, the DS scripts are forced to use the Sun
LDAP tools and some of the TET clu tests fail due to the differences.
Comment 1 Noriko Hosoi 2007-03-12 19:44:08 EDT
Created attachment 149885 [details]
svn diff mozldap6.spec

Change:
1. Setting %{mylibdir}/%{base_name} to mybindir, which is used for
pkgconfig/mozldap6.pc.
2. Using the variable mybindir for the LDAP tool location.
Comment 2 Nathan Kinder 2007-03-13 11:15:32 EDT
Looks good!
Comment 3 Noriko Hosoi 2007-03-13 13:22:54 EDT
Created attachment 149952 [details]
cvs diff (build_*mozldap*, mozldap6.spec)

In addition to the changes in comment #1, increased the release number to 6.
Comment 4 Noriko Hosoi 2007-03-13 13:27:57 EDT
Created attachment 149953 [details]
svn commit message

Thanks to Nathan for the clues for debugging as well as reviewing the changes.

Checked in into HEAD.
Comment 5 Noriko Hosoi 2007-03-13 14:37:41 EDT
Pushed the package files to /share/builds/sandbox/dirsec/current/pkgs/sparcv9/5.9.
Then re-catalog'ed:
cd /share/builds/sandbox/dirsec
./recatalog
=================  32-bit Red Hat (Solaris 9)  =================
================================================================

=================  64-bit Red Hat (Solaris 9)  =================
================================================================
Comment 6 Nathan Kinder 2007-12-21 14:17:30 EST
Verified that mozldap6.pc on Solaris uses a bindir of /usr/lib/sparcv9/mozldap6.
 Our clu test suite also verifies that this fix is working properly.

Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.