Bug 231971 - paps not working on some locale
paps not working on some locale
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: paps (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n, Reopened
Depends On: 231916
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-13 08:10 EDT by Akira TAGOH
Modified: 2013-04-12 15:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: paps-0.6.6-18.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 04:41:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2007-03-13 08:10:31 EDT
+++ This bug was initially created as a clone of Bug #231916 +++

Description of problem:

paps result is not displayed by evince or gv.

Version-Release number of selected component (if applicable):

paps-0.6.6-18.fc7

How reproducible:

always

Steps to Reproduce:
1.
echo AAA > t.txt
2.
paps t.txt > t.ps
3.
evince t.ps

Actual results:

ERROR: /undefined in 0,001000
Operand stack:
   (AAA)
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval--   --nostringval--   --nostringval--   %loop_continue  
--nostringval--   --nostringval--
Dictionary stack:
   --dict:1122/1686(ro)(G)--   --dict:0/20(G)--   --dict:103/200(L)--  
--dict:27/29(L)--   --dict:7/11(L)--   --dict:13/18(L)--   --dict:3/3(L)--
Current allocation mode is local
Last OS error: 2
ESP Ghostscript 815.03: Unrecoverable error, exit code 1

** (evince:18421): WARNING **: Interpreter failed.


Expected results:

no error.

Additional info:

Looking at the stack trace seems like it is a ghostscript
trace in both cases. So maybe the error is in ghostscript,
but I doubt it since it also happens on Centos4.

-- Additional comment from tagoh@redhat.com on 2007-03-12 21:42 EST --
I'm sorry but it works for me.
Can you provide me some information, such as your locale, the versions of
ghostscript, pango, all the fonts packages installed. also attach your t.ps into
bugzilla, please. the result of fc-match {Sans,Serif,Monospace} would be helpful
too.

-- Additional comment from pertusus@free.fr on 2007-03-13 05:01 EST --
locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=


ghostscript-8.15.3-7.fc7
pango-1.16.0-1.fc7


urw-fonts-2.3-6.1.1
xorg-x11-fonts-misc-7.1-3.fc7
xorg-x11-fonts-ISO8859-1-100dpi-7.1-3.fc7
bitmap-fonts-0.3-5.1.2.fc7
artwiz-aleczapka-fonts-1.3-5.fc6
xorg-x11-fonts-base-7.1-3.fc7
xorg-x11-fonts-ISO8859-1-75dpi-7.1-3.fc7
bitstream-vera-fonts-1.10-7
xorg-x11-fonts-truetype-7.1-3.fc7
dejavu-lgc-fonts-2.15-1
libdockapp-fonts-0.6.1-2.fc7
mplayer-fonts-1.1-4.lvn6
xorg-x11-fonts-75dpi-7.1-3.fc7
tetex-fonts-3.0-36.fc7
xorg-x11-font-utils-7.1-2
xorg-x11-fonts-100dpi-7.1-3.fc7
ghostscript-fonts-5.50-16.fc7
xorg-x11-fonts-Type1-7.1-3.fc7


$ fc-match Sans
DejaVuLGCSans.ttf: "DejaVu LGC Sans" "Book"
$ fc-match Serif
DejaVuLGCSerif.ttf: "DejaVu LGC Serif" "Book"
$ fc-match Monospace
DejaVuLGCSansMono.ttf: "DejaVu LGC Sans Mono" "Book"


-- Additional comment from pertusus@free.fr on 2007-03-13 05:02 EST --
Created an attachment (id=149910)
postfix output


-- Additional comment from pertusus@free.fr on 2007-03-13 05:05 EST --
(In reply to comment #3)
> Created an attachment (id=149910) [edit]
> postfix output

postscript output ;-) (to be clear, I use esmtp ;-).

-- Additional comment from tagoh@redhat.com on 2007-03-13 06:23 EST --
Ok, thank you for your info. well, the problem is that the style of the real
number is changed against your locale. PostScript doesn't affect such numeric
formats from locale in its syntax as well as other script languages.

For your workaround till this get fixed, set LC_NUMERIC=C and run paps would works.
Comment 1 Akira TAGOH 2007-03-13 08:12:05 EDT
This issue affects to all the plain text printing via lpr as well.
Comment 2 RHEL Product and Program Management 2007-06-05 16:34:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 6 Akira TAGOH 2008-05-16 09:22:12 EDT
Fixed in 0.6.6-18.el5.
Comment 8 Hao Liu 2008-05-19 09:51:37 EDT
I tried paps-0.6.6.18.el5 on RHEL-5.1-Client with following the steps:
1. Save attachment 149910 [details] to t.ps on my local machine
2. '#evince t.ps' in the terminal, following error messages given:

ERROR: /undefined in 0,001000
Operand stack:
   (AAA)
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval--   --nostringval--   --nostringval--   %loop_continue  
--nostringval--   --nostringval--
Dictionary stack:
   --dict:1122/1686(ro)(G)--   --dict:0/20(G)--   --dict:103/200(L)--  
--dict:27/29(L)--   --dict:7/11(L)--   --dict:13/18(L)--   --dict:3/3(L)--
Current allocation mode is local
Last OS error: 2
ESP Ghostscript 815.03: Unrecoverable error, exit code 1

** (evince:18421): WARNING **: Interpreter failed.


Seems the bug has been fixed in 0.6.6-18.el5.
Comment 9 Hao Liu 2008-05-19 09:56:16 EDT
Revise the last line of comment #8:
Seems the bug has not been fixed in 0.6.6-18.el5.
Comment 10 Akira TAGOH 2008-05-19 11:12:34 EDT
(In reply to comment #8)
> I tried paps-0.6.6.18.el5 on RHEL-5.1-Client with following the steps:
> 1. Save attachment 149910 [details] [edit] to t.ps on my local machine
> 2. '#evince t.ps' in the terminal, following error messages given:

No wonder you saw the error with the above attachment because the above steps
doesn't refer to paps at all. it was a PostScript file that generated by old
paps. please follow the original steps to reproduce and confirm a fix.
Comment 11 Hao Liu 2008-05-19 22:08:59 EDT
(In reply to comment #10)
> (In reply to comment #8)
> > I tried paps-0.6.6.18.el5 on RHEL-5.1-Client with following the steps:
> > 1. Save attachment 149910 [details] [edit] [edit] to t.ps on my local machine
> > 2. '#evince t.ps' in the terminal, following error messages given:
> 
> No wonder you saw the error with the above attachment because the above steps
> doesn't refer to paps at all. it was a PostScript file that generated by old
> paps. please follow the original steps to reproduce and confirm a fix.
> 

yup, following the steps given by the comment#0 can't reproduce the bug. Here
are some configurations of my testing machine:

$locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

$rpm -qa | grep paps
paps-0.6.6-18.el5

$rpm -qa | grep ghostscript
ghostscript-8.15.2-9.1.el5_1.1

$rpm -qa | grep pango
pango-1.16.0-1.fc7

$rpm -qa | grep fonts
xorg-x11-fonts-75dpi-7.1-2.1.el5
xorg-x11-fonts-truetype-7.1-2.1.el5
urw-fonts-2.3-6.1.1
tetex-fonts-3.0-33.2.el5_1.2
liberation-fonts-0.2-2.el5
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5
fonts-chinese-3.02-12.el5
bitstream-vera-fonts-1.10-7
bitmap-fonts-0.3-5.1.1
dejavu-lgc-fonts-2.10-1
xorg-x11-fonts-misc-7.1-2.1.el5
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2.1.el5
xorg-x11-fonts-Type1-7.1-2.1.el5
ghostscript-fonts-5.50-13.1.1
xorg-x11-fonts-base-7.1-2.1.el5
xorg-x11-fonts-100dpi-7.1-2.1.el5


$fc-match Sans
DejaVuLGCSans.ttf: "DejaVu LGC Sans" "Book"
$fc-match Serif
DejaVuLGCSerif.ttf: "DejaVu LGC Serif" "Book"
$fc-match Monospace
DejaVuLGCSansMono.ttf: "DejaVu LGC Sans Mono" "Book"


Comment 12 Akira TAGOH 2008-05-20 03:59:37 EDT
Okay, sorry for taking a long time for this bug. this was introduced by the fix
of Bug#212154, which isn't yet applied in RHEL5. so we could just ignore this bug.
Well, this patch itself takes no effects for anything since paps doesn't invoke
setlocale(3) at all though, if necessary, I could get rid of that patch from rpm.
Comment 13 Lawrence Lim 2008-05-20 04:37:26 EDT
Not sure if another respin is allowed to pull out the patch though. However,
risk is low keeping the patch in.

Note You need to log in before you can comment on or make changes to this bug.