Bug 232017 - Text does not render in Inventor
Text does not render in Inventor
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Inventor (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-13 12:06 EDT by Buddy Becker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.1.5-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 17:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Buddy Becker 2007-03-13 12:06:40 EDT
Description of problem:
Text does not render in open inventor.  I've seen it in both the open inventor
examples and code I'm working on.

Version-Release number of selected component (if applicable):
Inventor 2.1.5-24.fc6

How reproducible:
Fully

Steps to Reproduce:
1. Install Inventor-examples 2.1.5-24.fc6
2. As root run "make 06.1.Text" in /usr/lib/Inventor/examples/Mentor/CXX
3. Run /usr/lib/Inventor/examples/Mentor/CXX/06.1.Text
  
Actual results:
The globe renders as it's suppose to, but no text shows up.

Expected results:
According to the documentation, there should be a text label over Africa and Asia.
Comment 1 Ralf Corsepius 2007-03-14 02:01:24 EDT
Confirmed, I can reproduce this issue.

Could you please try the following:

# yum install dejagnu-fonts
# cd /usr/share/Inventor/fonts
# ln -s /usr/share/fonts/dejavu-fonts/DejaVuSerif.ttf Times-Roman

Then rerun 06.1.Text (or any other 06.*).
Comment 2 Buddy Becker 2007-03-14 15:30:57 EDT
That fixed the demos, thanks.
Comment 3 Ralf Corsepius 2007-03-14 17:39:34 EDT
Thanks for testing, should be fixed in *-26

Note You need to log in before you can comment on or make changes to this bug.